Older Aeotec Nano devices not reporting state change in OH 3.0.0

As per the title and apologies if this is a known quantity.

I have noticed since upgrading to OH 3.0.0, from 2.5.4 I believe, that my 4 original Nano dimmers no longer send updates when I use the physical wall switch.

This also applies to 3 original nano switches.

I have since installed the latest firmware upgrade, still no change. Tried both hail cc and basic. Also tried the trick with forced broadcast on wattage change

I haven’t excluded and included yet, as I didn’t feel like unscrewing the wall plates today.

Newer dual nano and brand new single nanos all work as expected.

Strangely, the same items have meta tags for Google Home and report correctly there.

Not really expecting a solution as such, just putting it out there for discussion and to see if anyone else is experiencing the same.

Try deleting the device Things from OH (NOT exclude) and rediscover / add them to get the latest settings.They will keep the same thingid so your Items and rulte will not break.

Thanks Bruce, sorry about the delayed reply.

I did that with one dimmer and one regular, but it doesn’t appear to have helped. I suspect I did this a few times previously also :slight_smile:

The only thing it’s really doing here to me is making my overview UI page kind of … not representative of what’s on and what’s off! Not a deal breaker, by any means.

I have noticed that it doesn’t update when the light status is altered via rules/scripts. When I use my Wallmote to turn on/off the bedroom lights from bed it doesn’t update then either. I do think you’re on the right track, my thoughts are also along the lines of it being some garbage data left over from the previous version.

You know, I just realised something. I don’t think I deleted and re-added after the firmware update!

Back to it, I will post an update :slight_smile:


Removed thing and associated items. Re-added. Same outcome, what a bother.

I found out yesterday that the OH3 binding database was about 3 weeks behind the OH2 export due to some repo changes. A PR was merged last night to update to the version in the 2.5 binding. The next snapshot build will have the updates. Perhaps missing database updates are part of the issue.

Awesome, I will likely do a clean install and try again with the snapshot. I assume going fresh with the updated database will solve. I was hoping a z-w-ave 7 hub would get certified for ANZ frequency before I rebuilt, but that looks unlikely.

Thank you for your input Bruce :smile:

zwave 7 CONTROLLERS will not work with the binding and a hub would require an OH binding to integrate, I believe.

Oh dear. Thanks for letting me know, that would have been upsetting!

More incentive to get another stick or hub as a backup then.

Where are you located? I noticed a good deal this week on the stickI use but it is only for North America.

Sorry, I short-handed Australia/New Zealand to ANZ! Local jargon not as obvious as my brain assumed.

All my devices are 921~Hz

Very frustrating at times.

I know @chris is moving to NZ. Perhaps he can recommend a stick

Sure! That would be great :smile:

Part of my original issue that sent me on this path was plugging in my aetoec zstick5 plus into an rpi4 as an “upgrade” to a faster control hub. Didnt realise that the silly stick isn’t compatible with rpi4.

Admittedly it’s an old stick and this problem has been addressed.

Well - until Chris gets to NZ, he doesn’t really know so much about the local scene :slight_smile: . However I’m sure that it’s the same in NZ as anywhere else in the world, and the Aeotec sticks are normally a pretty good bet. Currently all sticks use pretty much the same hardware and almost exactly the same firmware, so the reality is there is little difference.

1 Like

Haha, no promises but I expect you’ll love it.

I’ve been quite happy with my old aeotec stick and switches, very likely to grab an updated version.

You guys are awesome. Thanks for all the hard work you put into OH, makes me look like a genius when people see my home automation.

Yeah - I’m a kiwi so have spent plenty of time in NZ - I’ve just been living in the UK for the past 26 years :roll_eyes:

1 Like