Onewire binding error

I’m trying to map DS2413 onewire item and this breaks the system.

Here is my mapping in .items:

Switch Light_GF_Living_Onewire_Real “Test Switch” { onewire=“deviceId=3A.D7C307000000;propertyName=PIO.A” } (GF_Living)

And when I post it to the server, I receive:

osgi> 15:23:32.851 [INFO ] [c.internal.ModelRepositoryImpl:98 ] - Refreshing model 'demo.items’
15:23:32.939 [DEBUG] [i.internal.GenericItemProvider:154 ] - Processing binding configs for items from model 'demo.items’
15:23:32.955 [DEBUG] [i.internal.GenericItemProvider:133 ] - Read items from model 'demo.items’
15:23:33.085 [INFO ] [runtime.busevents :26 ] - Light_GF_Living_Onewire_Real state updated to ON
15:23:33.403 [INFO ] [.service.AbstractActiveService:181 ] - HTTP Refresh Service has been shut down

After that all mappings that goes below are disappear from the web interface.

There is no obvious error message however and I’m not sure what I’m doing wrong.

Still not able to find a solution… Any clue is greatly appreciated!

Try the correct order sequence:
Switch Light_GF_Living_Onewire_Real "Test Switch" (GF_Living) { onewire="deviceId=3A.D7C307000000;propertyName=PIO.A" }

1 Like

Thanks so much, this solved the issue!