Onewire Contact input issue

I have a 1Wire network that has been running under Misterhouse for >10 years.
I have decided to bring it across to OH via OWFS and the OneWire binding.
To experiment, I have setup a second Pi with openhabian
Version: 2.5.0-SNAPSHOT (#1627)
and OneWire 2.5
I ran into a couple of issues and still not clear about the channel config on the OWSerevr bridge.
Basically it would not pickup anything until I created a channel but the info I put in was rubbish ie “Dunno”. But after I did this, it scanned the network and detected the four things.

I have been using the paper interface for ALL configuration.

I now finally have it to a state whereby it detects some devices and I can toggle a relay on channel A (1) of a DS2406 On & Off. My issue is that on the same DS2406, channel B (2) is an Input and I cannot get this to work. The Things is a follows

Dual Digital I/O (12.9B200B000000) - Basic 1 wire Sensor

Digital I/O 0 - Mode = Output, Channel Logic = Normal
Digital I/O 1 - Mode = Input, Channel Logic = Normal
I have a refresh time set to 1 second (This is a PIR input for controlling lights) but I have tried longer.

The Item “Digital I/O 1” is defined as a Contact.



Did you try using switch as item-type?

Yes, I started this way, then moved to it being a contact, which it is.

It’s probably not what you meant, but just in case; that would be an invalid Item name.
Digital_IO_1 would be okay.

So far as I read the Onewire binding doc, there is no channel support for Contact type Items.

The name was assigned by the paper interface and I probably did not type it into the message correctly. Should have copied and pasted.

So how do you read a channel that is defined as an input?

Use Switch. If necessary you can connect the channel to a intermediate item and map that to open/close for the contact item in a rule.

Hi Jan,
When I had it set as a switch, the switch state did not change with a change on the physical input.
Note - I have verified the input operation on my old Misterhouse and via the Maxim app.

What needs to be done to set the DIO into input mode? I’m not familiar

Strange. I‘m using the binding with DS2413 and that works fine. Please set the binding to DEBUG mode and switch the contact. I would like to see what is going wrong there. You definitely need to use a Switch item, Contact is not supported.

for everyone coming around here: maybe this might help you…