Onkyo binding support for HT-RC660


I am trying to setup OpenHab 2.1.0 Onkyo binding with an Onkyo HT-RC660 AV receiver.
I can confirm in doesn’t work with this device. It is discovered and clearly marked as “Unsupported”,

I was wondering what can be done to provide support for more Onkyo devices, as the HT-RC660.
The list of supported devices is not very long.
Is there are reason to not support other devices that do implement the eISCP protocol?


I’m working on a common binding for A/V stuff controlled via TCP or Serial connection.
Have tested basic functions with Yamaha and Denon receivers, Epson projectors and Samsung TVs/Set top boxes, but that’s as far as my network connected devices go.
I did just implement a support for Onkyo protocol, but haven’t been able to test it yet. The only Onkyo I have is from years ago and has only a serial connection available, I need to dig it up from the attic and connect with serial to ethernet module. If you are interested, I could send you the dev version. It’d be nice to get some feedback and especially an idea if the Onkyo support works as it has been developed now a bit blindfolded.


Is this a different binding, isn’t it?

I could give it a try, although I think it is a bit optimistic to gather all type of devices in a single binding. Onkyo receivers work with the eISCP protocol. I think the protocol is exclusive of Onkyo.
I guess other receivers would use different protocols. ¿?

In any case, does someone have an answer for the support of HT-RC660 in the Onkyo binding?

They all sure have different protocols, but as they all share common lower layer communication structure and only the commands differ, making a common binding is actually quite straight forward. The different commands are managed with different thing xml files.

You could look at it as a bit of a more user friendly version of the TCP binding already available.

But it would be great if you could give it a try, as mentioned the current onkyo support is not tested at all, so I will first check if it works ok with my old onkyo, then share the jar with you.


where to find the binding? I have a HT-RC440 and could do some testing

I need to check with one Onkyo I found to just verify even the basics work. I will have some time in a week or so to try it out. Apologies for the delay.

any information required, which I could provide?

Hi. @Rooster, any update on the binding? Where to find?
I tried with HTC-440 and it works, just missing Zone2 in Paper UI.

Hi there,
So time flies.
Just today had a chance to try an Onkyo receiver, and was able to see for myself if it worked at all, and it didn’t. However, it was an error in my eiscp implementation, and now it is “fixed” I haven’t been able to test the fix yet at all with an Onkyo receiver, so with that caviat:

The only function that may work is power/standby for now and reading back the changes done locally at the receiver won’t work for sure. But, if the power/standby works, then adding the other functions would just require adding the functions to the thing xml file based on eiscp specs.

This works now with Denon (Marantz would but is not recoginized) and Yamaha receivers at least, doesn’t include all the available functions thou. Additionally, Epson Projectors are supported

Adding Zone2 controls to Onkyo should be easy to the xml once this connection works ok.

Just uploaded a fresh version, it might actually be able to turn Zone2 on/off

Hi There,

Did upload a new version. I was able to verify with TX-NR609 that power and mute work ok. Volume control works as well, but it has to be tuned to support eiscp hex volume control.

Commands from the receiver are also handled now by the binding, so openhab gets updated on changes done at the receiver.

If you could verify the basics work on HT-RC660, we can then take it forward.


Ok, now the volume controls are ok for Onkyo as well.

If there happened to be someone around with a Marantz receiver, it would be great if you could give it a try if the device is discovered correctly and works ok? Marantz work the same as Denon, so they should, but cannot verify myself

Hi @Rooster, I have Openhab 2.2 and an Onkyo TX-NR609 if you want me to do some testing…?

Of course if you have another receiver to try it would be helpful. Have been out of this for a few months now, occupied with other engagements. Let me know if there is something you find missing or not working

@Rooster I need some help to get the onkyo binding working.

I have a HT-RC440 connected to my network. The receiver gets an IP address using DHCP (also seen on the router for that mac address). The network standby is enabled and its powered on.

However, after installing the 2.4M7 release and the Onyko binding the auto discovery doesn’t detect the receiver.

When I manually add a thing (using the generic thing type) it goes online and the log shows a connected message, but no functions works. The log shows traffic

2018-12-10 11:49:04.712 [DEBUG] [nding.onkyo.internal.OnkyoConnection] - Test connection to
2018-12-10 11:49:04.717 [DEBUG] [nding.onkyo.internal.OnkyoConnection] - Send command: [command=PWR, value=QSTN] to (Socket[addr=/,port=60128,localport=33602])
2018-12-10 11:49:04.724 [TRACE] [g.onkyo.internal.eiscp.EiscpProtocol] - Created eISCP message: 49534350000000100000000A0100000021315057525153544E0D -> ISCP[00][00][00][10][00][00][00][LF][01][00][00][00]!1PWRQSTN[CR]
2018-12-10 11:49:04.728 [TRACE] [nding.onkyo.internal.OnkyoConnection] - Sending 26 bytes: 49534350000000100000000A0100000021315057525153544E0D

but nothing happens.

2018-12-10 11:49:25.964 [DEBUG] [nding.onkyo.internal.OnkyoConnection] - No data received during supervision interval (70000 ms)!
2018-12-10 11:49:25.968 [DEBUG] [nding.onkyo.internal.OnkyoConnection] - Reconnecting...
2018-12-10 11:49:25.974 [DEBUG] [nding.onkyo.internal.OnkyoConnection] - Connected to

ping works and also telnet to port 60128 connects, but entering something doesn’t show any result (no sure if the protocol is ASCII)

Also the Onkyo App for iOS doesn’t find the receiver.

Anything I could validate?

Not sure as I don’t have much to do with the actual Onkyo binding, but as you described the issue, it sounds like there is something faulty with your receiver. This based on the fact your iOS app cannot connect either.

I had a similar issue with one Yamaha at some point, there a factory reset helped