Onkyo Binding TX-NR626

Tags: #<Tag:0x00007fe7368662b0> #<Tag:0x00007fe7368661e8> #<Tag:0x00007fe736866120>

Hi,

I just wanted to confirm that the Onyko Binding works with Onkyo TX-NR626 in openHAB2 (OH2).

The Input selection is a bit different:

01="CBL/SAT", 02="GAME", 03="AUX", 05="PC", 16="BD/DVD", 34="PHONO", 35="TV/CD", 36="FM", 37="AM", 39="NETWORK", 41="USB", 46="BLUETOOTH"

Here is my example, if you want to use it with sitemaps.

sitemap: (replace the channel string with what you find in Paper UI!)

// Onkyo
Switch    Onkyo_Power        { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone1#power" }
Number    Onkyo_Input  { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone1#input" }
Dimmer    Onkyo_Volume { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone1#volume" }
Switch    Onkyo_Mute { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone1#mute" }
Player    Onkyo_Control { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:player#control" }
String    Onkyo_PlayingTime { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:player#currentPlayingTime" }
String    Onkyo_Title { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:player#title" }
String    Onkyo_Album { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:player#album" }
String    Onkyo_Artist { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:player#artist" }
Number    Onkyo_ListenMode { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:player#listenmode" }

Switch    OnkyoZ2_Power        { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone2#power" }
Number    OnkyoZ2_Input  { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone2#input" }
Dimmer    OnkyoZ2_Volume { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone2#volume" }
Switch    OnkyoZ2_Mute { channel="onkyo:onkyoUnsupported:f6b04f6a-fa4f-6ab9-d646-6a09fab9f34a:zone2#mute" }

Sitemap:

Frame label="ONKYO" {
    Switch        item=Onkyo_Power label="Power"
    Setpoint    item=Onkyo_Volume label="Volume" icon="audio" minValue="0" maxValue="50" step="1" visibility=[Onkyo_Power==ON]
    Switch        item=Onkyo_Mute label="Mute" visibility=[Onkyo_Power==ON]
    Selection    item=Onkyo_Input label="Input" mappings=[01="CBL/SAT", 02="GAME", 03="AUX", 05="PC", 16="BD/DVD", 34="PHONO", 35="TV/CD", 36="FM", 37="AM", 39="NETWORK", 41="USB", 46="BLUETOOTH"] visibility=[Onkyo_Power==ON]
}

Hi!
I want to confirm that my Onkyo TXNR636 is working to, but sometime I get this error:

12:17:32.419 [ERROR] [b.binding.onkyo.handler.OnkyoHandler] - Exception in statusUpdateReceived for Onkyo Receiver @192.168.9.73:60128. Cause: For input string: "N/", data received: LMDN/A

But all is working well. I’ve not tested the player item, not sure how to use it.

Tom

I see similar errors in the log
`
21:12:26.014 [ERROR] [b.binding.onkyo.handler.OnkyoHandler] - Exception in statusUpdateReceived for Onkyo Receiver @192.168.3.52:60128. Cause: For input string: “N/”, data received: LMDN/A

21:19:09.143 [ERROR] [b.binding.onkyo.handler.OnkyoHandler] - Exception in statusUpdateReceived for Onkyo Receiver @192.168.3.52:60128. Cause: For input string: “N/”, data received: SLIN/A

21:19:27.413 [ERROR] [b.binding.onkyo.handler.OnkyoHandler] - Exception in statusUpdateReceived for Onkyo Receiver @192.168.3.52:60128. Cause: For input string: “N/”, data received: LMDN/A
`

I have a model 656, similar error. Any idea what is driving this?

Hi there!
I can reproduce this LMDN/A error when I select a not available(N/A) listening mode. Your SLIN/A probably means that you try to select a not available input source. Not sure how to solve this, because sometime it’s happen when I’m not selecting a not available listening mode.

Great. I submitted a PR to fix these exceptions. In my test environment it runs much better now.
incl the right zone2 info & having all the listen modes & sources in the UI

Hi

I have an ONKYO 626 an Openhabian running on a Raspberry Pi2.

I control my Onkyo with the remote App without any issues, but as soon as i connect the Onky to my openhab system via Paper UI, it works for about 2-5 hours and then the receiver can´t be found anymore. Not via the app, and no control via openhab. If i delete the binding, and disconnect the receiver from the power outlet for a few minutes, it works again.

I have no clua, what openhab does to the receiver.

THX
Daniel