Oomi bulb zwave not responding to controls

Tags: #<Tag:0x00007f617363e170>

Hi guys,

I have setup a new openhab 2. 5 on Ubuntu.
I installed successfully a few things and today I setup a z stick zwave controler by aeotec
I search for zwave things. I added door/window sensor and electric plugs successfully however i have trouble with 2 types of devices
Oomi Multisensor and bulb by fantem which are basically modified aeotec items.
The bulb is not responding to any controls and the multisensor only provides 3 channels. I cannot see any light sensor, humidity or ultraviolet information

Do they show up as Unknown Devices?

The show up properly with a description of the device and their capabilities.

Please post the configuration for your Items that are not functioning.

Ok it seems that the definitions for these devices are not correct. For the multisensor it is missing parameters from the xml file. I flashed the firmware and converted it to AEOTEC multisensor 6 which is basically the same device and now all channels and parameters show properly.

Now remains the bulb. I am not sure if this one can be updated to the aeotec firmware.
any ideas?
I will post the device configuration shortly

These are the channels that appear for the Bulb. I have a feeling that the xml file is not proper for this device as it was for the multisensor

Dimmer LaundryRoomLightSwitchDimmer “Dimmer” (GF_Laundry) {channel=“zwave:device:0b2ecca1:node6:switch_dimmer”}

Color LaundryRoomLightColorColor “Color control” (GF_Laundry) {channel=“zwave:device:0b2ecca1:node6:color_color”}

Dimmer LaundryRoomLightColorTemperature “Color temperature” (GF_Laundry) {channel=“zwave:device:0b2ecca1:node6:color_temperature”}

We need to see the xml file generated by OH to see what the device is actually sending.It is in the zwave folder under `userdata.

0xe02c49ee 6 4 0x16a 0x62 0x3 false false true false true 40000 1000 COMMAND_CLASS_SWITCH_MULTILEVEL COMMAND_CLASS_SWITCH_COLOR COMMAND_CLASS_CONFIGURATION COMMAND_CLASS_MANUFACTURER_SPECIFIC COMMAND_CLASS_FIRMWARE_UPDATE_MD 0 BASIC_TYPE_ROUTING_SLAVE GENERIC_TYPE_SWITCH_MULTILEVEL SPECIFIC_TYPE_POWER_SWITCH_MULTILEVEL 0 COMMAND_CLASS_SWITCH_COLOR 0 1 false 0 PURPLE RED COLD_WHITE BLUE WARM_WHITE GREEN PURPLE RED COLD_WHITE BLUE WARM_WHITE GREEN true COMMAND_CLASS_HAIL 0 0 false 0 COMMAND_CLASS_CONFIGURATION 0 1 false 0 32 32 1 0 false false 33 33 4 16711680 false false 34 34 1 0 false false 35 35 1 1 false false 20 20 1 1 false false COMMAND_CLASS_SWITCH_MULTILEVEL 0 1 false 0 true COMMAND_CLASS_MANUFACTURER_SPECIFIC 0 1 false 0 false 362 3 98 COMMAND_CLASS_FIRMWARE_UPDATE_MD 0 1 false 0 COMMAND_CLASS_NO_OPERATION 1 1 false 1 COMMAND_CLASS_BASIC 0 1 false 0 true 2020-02-11 11:19:18.93 UTC

@Yiannis550, without code fences, the XML loses all of its formatting.

1 Like

not sure how to copy the file so it retains the formatting. I have shared it on my google drive with below link

That file may work, but for future reference,
How to use code fences - Tutorials & Examples - openHAB Community

1 Like
<node>
  <homeId>0xe02c49ee</homeId>
  <nodeId>6</nodeId>
  <version>4</version>
  <manufacturer>0x16a</manufacturer>
  <deviceId>0x62</deviceId>
  <deviceType>0x3</deviceType>
  <listening>false</listening>
  <frequentlyListening>false</frequentlyListening>
  <routing>true</routing>
  <security>false</security>
  <beaming>true</beaming>
  <maxBaudRate>40000</maxBaudRate>
  <sleepDelay>1000</sleepDelay>
  <nodeInformationFrame>
    <commandClass>COMMAND_CLASS_SWITCH_MULTILEVEL</commandClass>
    <commandClass>COMMAND_CLASS_SWITCH_COLOR</commandClass>
    <commandClass>COMMAND_CLASS_CONFIGURATION</commandClass>
    <commandClass>COMMAND_CLASS_MANUFACTURER_SPECIFIC</commandClass>
    <commandClass>COMMAND_CLASS_FIRMWARE_UPDATE_MD</commandClass>
  </nodeInformationFrame>
  <associationGroups class="concurrent-hash-map"/>
  <endpoints class="concurrent-hash-map">
    <entry>
      <int>0</int>
      <endPoint>
        <deviceClass>
          <basicDeviceClass>BASIC_TYPE_ROUTING_SLAVE</basicDeviceClass>
          <genericDeviceClass>GENERIC_TYPE_SWITCH_MULTILEVEL</genericDeviceClass>
          <specificDeviceClass>SPECIFIC_TYPE_POWER_SWITCH_MULTILEVEL</specificDeviceClass>
        </deviceClass>
        <endpointId>0</endpointId>
        <secureCommandClasses/>
        <supportedCommandClasses class="concurrent-hash-map">
          <entry>
            <commandClass>COMMAND_CLASS_SWITCH_COLOR</commandClass>
            <COMMAND__CLASS__SWITCH__COLOR>
              <version>0</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
              <supportedColors>
                <colorType>PURPLE</colorType>
                <colorType>RED</colorType>
                <colorType>COLD_WHITE</colorType>
                <colorType>BLUE</colorType>
                <colorType>WARM_WHITE</colorType>
                <colorType>GREEN</colorType>
              </supportedColors>
              <refreshList>
                <colorType>PURPLE</colorType>
                <colorType>RED</colorType>
                <colorType>COLD_WHITE</colorType>
                <colorType>BLUE</colorType>
                <colorType>WARM_WHITE</colorType>
                <colorType>GREEN</colorType>
              </refreshList>
              <colorMap/>
              <isGetSupported>true</isGetSupported>
            </COMMAND__CLASS__SWITCH__COLOR>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_HAIL</commandClass>
            <COMMAND__CLASS__HAIL>
              <version>0</version>
              <instances>0</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
            </COMMAND__CLASS__HAIL>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_CONFIGURATION</commandClass>
            <COMMAND__CLASS__CONFIGURATION>
              <version>0</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
              <configParameters>
                <entry>
                  <int>32</int>
                  <configurationParameter>
                    <index>32</index>
                    <size>1</size>
                    <value>0</value>
                    <readOnly>false</readOnly>
                    <writeOnly>false</writeOnly>
                  </configurationParameter>
                </entry>
                <entry>
                  <int>33</int>
                  <configurationParameter>
                    <index>33</index>
                    <size>4</size>
                    <value>16711680</value>
                    <readOnly>false</readOnly>
                    <writeOnly>false</writeOnly>
                  </configurationParameter>
                </entry>
                <entry>
                  <int>34</int>
                  <configurationParameter>
                    <index>34</index>
                    <size>1</size>
                    <value>0</value>
                    <readOnly>false</readOnly>
                    <writeOnly>false</writeOnly>
                  </configurationParameter>
                </entry>
                <entry>
                  <int>35</int>
                  <configurationParameter>
                    <index>35</index>
                    <size>1</size>
                    <value>1</value>
                    <readOnly>false</readOnly>
                    <writeOnly>false</writeOnly>
                  </configurationParameter>
                </entry>
                <entry>
                  <int>20</int>
                  <configurationParameter>
                    <index>20</index>
                    <size>1</size>
                    <value>1</value>
                    <readOnly>false</readOnly>
                    <writeOnly>false</writeOnly>
                  </configurationParameter>
                </entry>
              </configParameters>
            </COMMAND__CLASS__CONFIGURATION>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_SWITCH_MULTILEVEL</commandClass>
            <multiLevelSwitchCommandClass>
              <version>0</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
              <isGetSupported>true</isGetSupported>
            </multiLevelSwitchCommandClass>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_MANUFACTURER_SPECIFIC</commandClass>
            <COMMAND__CLASS__MANUFACTURER__SPECIFIC>
              <version>0</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
              <initSerialNumber>false</initSerialNumber>
              <deviceManufacturer>362</deviceManufacturer>
              <deviceType>3</deviceType>
              <deviceId>98</deviceId>
            </COMMAND__CLASS__MANUFACTURER__SPECIFIC>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_FIRMWARE_UPDATE_MD</commandClass>
            <COMMAND__CLASS__FIRMWARE__UPDATE__MD>
              <version>0</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
            </COMMAND__CLASS__FIRMWARE__UPDATE__MD>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_NO_OPERATION</commandClass>
            <COMMAND__CLASS__NO__OPERATION>
              <version>1</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>1</versionSupported>
            </COMMAND__CLASS__NO__OPERATION>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_BASIC</commandClass>
            <COMMAND__CLASS__BASIC>
              <version>0</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
              <isGetSupported>true</isGetSupported>
            </COMMAND__CLASS__BASIC>
          </entry>
        </supportedCommandClasses>
      </endPoint>
    </entry>
  </endpoints>
  <nodeNeighbors/>
  <lastReceived>2020-02-11 11:19:18.93 UTC</lastReceived>
</node>

I think the propblem is that it is set to not always listening. I have used zwave PC Controller software and enabled always listening and then I can communicate with the bulb from that software. However if I exit and start the software again the bulb is back to not listening. How can this listening mode be changed permanently? It should be on anyway. The AEOTEC bulb gen 5 (same HW different brand) is always on.

It is not possible to change this - it comes from the device itself and is provided by the protocol.

Many thanks for your support. with help from Aeotec excellent support I managed to convert my bulb to a ZW098 and now it works!! It seems XML files for this device aeotec version is ok.
I had the same kind of issues with the multisensors. Converted to aeotec firmware and now they work!
Now I have to convert all my bulbs (about 20 of them)

1 Like

Hello Yiannis,

it is great to read that you were able to change the bulb to the aeotec device. could you please describe the steps and used hardware/software to change it.
I put the bulbs away after i could not change the firmware for them . It would be great to use them again.

Thanks,
Martin

Hi!
I contacted aeotec and they have send me a software to use with my z stick.
I install z stick on a Windows laptoo and run that software. It would show all the devices registered on my z ztick. I choose the bulb and uncheck the queue box so it will perform a force command on the device.
Then send the new firmware to it.
Laptop has to be as close to device as possible. Maybe about 2-3 meters was ok for me.

I hope it helps! Let me know if you need anything and i can help.

I also converted my multisensors and siren to aeotec firmware.
Now the only oomi useless stuff i have is the cube itself and oomi touch. I wish i could repurpose those too to he useful in some way.

Hi,

i have the following version of the software: OTA_of LED_Bulb_EU_A_V1_05 _20160909 and my devices are z-stick ZW 090-C and the Bulbs FT098-C55.

unfortunatly it is not working for me :frowning:

When I force the Update I get an error: received status invalid combination.

Do you have the same combination and softwareversion or another one?

For my other devices like multisensor or the lightstripe(now I can set the colors) the updates were successful and they are working with my openhab installation just fine for some time.

the oomi cube is useless but with the tab I was able to open a browser and access the webinterface of my openhab installation.

My software is 1_07. It is the latest I got from Aeotec about a month ago. If you want I can sent it to you by email. it is about 1MB zipped.
Some bulbs I had to reset to factory default before upgrading the firmware. Some were ok from first try without resetting.

How did you opened a browser on OOMI touch? Also do you know how I can default all the settings for it?