Openhab 2.4.0 Release fails at startup

Tags: #<Tag:0x00007f616e15d818>

I upgraded to 2.4.0 and everything was working smoothly, then i restarten windows pc
and suddently this happens and karaf console closes

Tried reinstalling java without any change
Checked java home

any pointers?

I
18:54:37.728 [WARN ] [org.apache.karaf.shell.ssh.SshUtils ] - Configured keyexchange ‘diffie-hellman-group-exchange-sha256’ not available
18:54:37.732 [WARN ] [org.apache.karaf.shell.ssh.SshUtils ] - Configured keyexchange ‘ecdh-sha2-nistp521’ not available
18:54:37.732 [WARN ] [org.apache.karaf.shell.ssh.SshUtils ] - Configured keyexchange ‘ecdh-sha2-nistp384’ not available
18:54:37.732 [WARN ] [org.apache.karaf.shell.ssh.SshUtils ] - Configured keyexchange ‘ecdh-sha2-nistp256’ not available
18:54:37.732 [WARN ] [org.apache.karaf.shell.ssh.SshUtils ] - Configured keyexchange ‘diffie-hellman-group-exchange-sha1’ not available
18:54:37.734 [WARN ] [org.apache.karaf.shell.ssh.SshUtils ] - Configured keyexchange ‘diffie-hellman-group1-sha1’ not available
18:54:37.766 [WARN ] [org.apache.karaf.shell.ssh.Activator ] - Error starting activator
java.lang.IllegalArgumentException: KeyExchangeFactories not set
at org.apache.sshd.common.util.ValidateUtils.createFormattedException(ValidateUtils.java:213) ~[62:org.apache.sshd.core:1.7.0]
at org.apache.sshd.common.util.ValidateUtils.throwIllegalArgumentException(ValidateUtils.java:179) ~[62:org.apache.sshd.core:1.7.0]
at org.apache.sshd.common.util.ValidateUtils.checkTrue(ValidateUtils.java:174) ~[62:org.apache.sshd.core:1.7.0]
at org.apache.sshd.common.util.ValidateUtils.checkNotNullAndNotEmpty(ValidateUtils.java:80) ~[62:org.apache.sshd.core:1.7.0]
at org.apache.sshd.common.helpers.AbstractFactoryManager.checkConfig(AbstractFactoryManager.java:475) ~[62:org.apache.sshd.core:1.7.0]

What Java version do you use? Did you try a recent Java 8 version?

Newest java used
jre1.8.0_191

Launching the openHAB runtime…
‘findstr’ is not recognized as an internal or external command,
operable program or batch file.
‘findstr’ is not recognized as an internal or external command,
operable program or batch file.
WARNING: Running Karaf on a Java HotSpot Client VM because server-mode is not available.
Install Java Developer Kit to fix this.
For more details see http://java.sun.com/products/hotspot/whitepaper.html#client
Listening for transport dt_socket at address: 5005

Maybe you can try the JDK instead? I see it also being used in the Windows installation guide.

Looks like findstr should normally be on your path:

https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Removed all traces of old javas in my system and installed this, seem to be working

Will update later if it fails again

Nope dont work same java error…

Ps, if i go back to 2.4.0 Build #1392 snapshot backup i have everything works fine

after some more investigating, IF I delete the cahce folder before trying to start up openhab gets no errors and start up fine

1 Like

I thaugt i found out what was causing the error/shutdown

https://pastebin.com/JUv9f7aW

Can someone have a look at the error log and tell me what is happening? Would make my day :), still if i delete contents OH cahce folder before startup, ot will start up and work fine.
I can also offer my teamviever.

Best regards Jack

Environment Variables:
JAVA_HOME=C:\Program Files (x86)\Java\jdk1.8.0_192
CLASSPATH=C:\OPENHA~2.0\userdata\conf;C:\openhab-2.4.0\runtime\bin…\lib\boot\activation-1.1.1.jar;C:\openhab-2.4.0\runtime\bin…\lib\boot\jaxb-api-2.3.0.jar;C:\openhab-2.4.0\runtime\bin…\lib\boot\jaxb-core-2.2.11.jar;C:\openhab-2.4.0\runtime\bin…\lib\boot\jaxb-impl-2.2.11.jar;C:\openhab-2.4.0\runtime\bin…\lib\boot\org.apache.karaf.diagnostic.boot-4.2.1.jar;C:\openhab-2.4.0\runtime\bin…\lib\boot\org.apache.karaf.jaas.boot-4.2.1.jar;C:\openhab-2.4.0\runtime\bin…\lib\boot\org.apache.karaf.main-4.2.1.jar;C:\openhab-2.4.0\runtime\bin…\lib\boot\org.osgi.core-6.0.0.jar
PATH=C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\System32;C:\OPENHA~2.0\userdata\lib;C:\openhab-2.4.0\runtime\bin…\lib
USERNAME=Matrixserver
OS=Windows_NT
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 62 Stepping 4, GenuineIntel

--------------- S Y S T E M ---------------

OS: Windows 10.0 , 64 bit Build 17134 (10.0.17134.1)

CPU:total 8 (initial active 8) (4 cores per cpu, 2 threads per core) family 6 model 62 stepping 4, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, avx, aes, clmul, erms, ht, tsc, tscinvbit

Memory: 4k page, physical 16711996k(12801244k free), swap 19202364k(13604096k free)

vm_info: Java HotSpot™ Client VM (25.192-b12) for windows-x86 JRE (1.8.0_192-b12), built on Oct 6 2018 16:11:13 by “java_re” with MS VC++ 10.0 (VS2010)

time: Fri Dec 21 10:15:49 2018
timezone: Vest-Europa (normaltid)
elapsed time: 26 seconds (0d 0h 0m 26s)

Still stuck at needing to delete Cahce folder before startup (windows10)
After startup everything works very well
@Kai, any suggestions?

Sorry for bothering you I try to find stuff on the forums but nothing helps

Best regards Jack

The crash in your dump comes from nrjavaserial, so you might want to try your system without Z-Wave for the start to see if it then starts up correctly.
If there’s a crash with nrjavaserial this could be due to the recent changes of that lib, but it’ll be hard to track down…

Ok, thanks for the answer, I will try without Zwave for a while
Whats weird is when i delete cahe folder and start openhab, everything works fine for a long time. But after a reboot the startup fails.

Will report back

@Kai, Happy NEw Year

Unfortunatly the wife is not so happy with openhab, she cant restart openhab by herself anymore because of this issue (i work offshore)

Tried without the zwave binding, but OH still has the same behaviour.

I have
RfXTrx
Zwave
Zigbee (telegesis)
That user serial com ports

I will try to remove Zigbee, it is the latest part added to the system.

But still 2.4.0 still works like a charm after deletin cahce

(starting to belive something maybe is broken java wise on my machine)

Best regards Jack

EUREKA!

Disabeling the port zwave dongle was on did the trick!

Is it drivers? or maybe the port it is plugged in? its weird because the dongle works fine in other software.

Maybe @chris has seen this before?

No - unfortunately (or, fortunately, depending on your perspective :wink: ) I’ve not seen this before and don’t really have any suggestions as to what it might be - sorry.

@Kai
@chris

YES! I have a soulution, I think

The driver that have the name UZB ( Z-Wave.Me) in system was probably the problem. Uninstalled the drivers and removed them for the system.
The reinstall of driver is called somting usb serial device (still from microsoft) But does not cause errors and crash at startup.

I have closed restarted and closed OH many times now without any fails
This is the usb stick

Regards Jack

1 Like

Oh crap, same behaviour after a restart today.

Disableing the com port in system before startup of oh, works (the zwave one)

Ive looked into

Tried swapping the nmjavaserial in openhab runtime but same issue persists

Need to take a brake before the lady gets mad :slight_smile:

No solution, but FYI.

I have the same problem, a crash of the JVM on startup on nrjavaserial.
I also have the UZB stick and I am using the driver from z-wave.me.

I do think however that the driver is fine.
I installed the OpenZWave library (https://github.com/OpenZWave/) and the example application that comes with it is runs fine with the stick.

1 Like

Yes, the stick runs fine on all other software in Windows Just fine.
I have tried everything i know.
I have two options to get OH running with the latest stable release

  1. Delte the cahche folder within OH before startup

  2. Disable the device in computer manager before startup. And enable IT again after OH is started. All works fine then

Did you find a solution to this? My wife starts to hate my system…

Currently looking at athom homey…

I gave up on it and moved to a laptop with Linux.
Everything is working fine.
I will move it to a Raspberry Pi later.