Openhab 2.4 & 2.5M1 bindings stop controlling items after weeks of normal operation

Tags: #<Tag:0x00007fc3f7b71a98> #<Tag:0x00007fc3f7b719d0>

My openhab 2.4 release installation worked for some weeks and suddenly starts to not control e.g. hue items or the nuki lock. Devices simply don’t react while log file looks normal. Items are predicted and reported in new state but they don’t react. In case of Nuki, I do receive status updates. For hue, this does not work either. Restarting openhab solves the problem … for some days/weeks.
I upgraded to 2.5M1 and have the same problems.

Does anybody know how to further analyze the problem?

Java is version “1.8.0_191”
Java™ SE Runtime Environment (build 1.8.0_191-b12)

Read the documentation on reading the log files.
https://www.openhab.org/docs/tutorial/logs.html
The logs will be giving you warnings and errors that need looking into. There is also the system log which may also have the reason logged if it is an OS issue.

There is a change some binding blocks the threads. You can analyse this using this: