openHAB 2.4 has been released!

Can confirm this (virus warning) on other Windows 10 machines.


My Defender version information:


no virus detection, but windows defender is scanning around 5 minutes until the file got successfully saved on disk


Did you ever get this resolved?
I have just upgraded 2.4 and everything is fine apart from the same sort of errors appearing when Im using the IOS app.

Did manage to destroy a Wifi LED controller which essentially overheated while I was upgrading and burned itself out even though the LED lights were off which was strange.

Anyhow only issue is the same sort of warnings as you listed.


I had similar problems after update. Did you solve it?

If you have issues with load and Basic UI disconnecting, maybe there is some addon that fails to install. See also Basic UI - continually disconnects 'waiting for server to become available'

@olialb & @KevinI
No I haven’t been able to fixed it directly. But I was addressing a separate issue with the IpCamera binding, and had to increase the Java JVM heapsize to 512. That seems to reduce the # of exceptions. I am not at home right now. I will confirm when I get home tonight. The the record, this happens with my Basic UI running in the desktop browser.

See this link on how to increase the heap memory: IpCamera: New IP Camera Binding

Hm, thanks for the hint. But I do not have an ipCamera…

Even if you don’t have a camera, as you add more items and rules, you may find that your system starts thrashing a lot. IMO, the default setting of 256MB might be quite low for many setups.


My issue related to the sync job continually loading 3 bindings and therefore causing additional load, Karaf console would also be really sluggish while the activity was going on, the following post help me diagnose/resolve the issue.

Essentially I enabled the karaf debug and then amended my addons.cfg file until I got all my bindings loaded and none reloading all the time.


1 Like

Thanks good hint, I will try and make another update round. I also deleted some bindings and stuff which I don’t use often. I hope this helps!

It may not be just a result of the load on the system. Invalid binding names in addons.cfg also causes a memory leak, which, over time may cause your system to swap (which will make it really slow) or crash.

Hey yfaway!! Thank you for hint! I increased the JAVA heap size in openHAB 2.3 and made again the update of openHAB 2.4.

Much much better. Stable like 2.3 and no strange exceptions anymore.

For eveyone with update problems and a bigger installation please consider this:

One of the things that stopped working for me after the update is MySQL persistence. No errors, just nothing getting logged. Nobody else?

Yes. I find it quite baffling how something so widely used just gets completely broken by default on an upgrade without any mention.

Ok, found out that things DO get logged just with the wrong timestamp (using the time of the database server rather than the local openhab time).
Is the “localtime=true” option in mysql.cfg no longer supported?

Guys, I’ve just done upgrade from 2.4 to 2.5 on Openhabian via:

apt-get update
apt-get upgrade

All packages was upgraded without any error. After upgrade was finished I was unable to start Openhab2. i have reboot Raspberry, few times restarted openhab2 process and still same result.
system show proces as working:

[20:28:34] root@openHABianPi:/home/pi# service openhab2 status
● openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-01-04 20:28:34 CET; 3min 57s ago
  Process: 1818 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited, status=0/SUCCESS)
 Main PID: 1961 (java)
   CGroup: /system.slice/openhab2.service
           └─1961 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.userd

Jan 04 20:28:34 openHABianPi systemd[1]: Started openHAB 2 - empowering the smart home.

All opanhab logs are empty , I can not access 8080 port :frowning:

Do I need to change something (I have never did it after upgrade) ?
Does somebody had similar problem ? Any ideas ?

EDIT: Problem solved after I forced to reinstall OH2. Still I have no idea why it was failled.

Hey guys i tried to upgrade from 2.3 to 2.4 and have been getting the following error message. Does anyone know how to fix this? Thanks

Reading package lists… Done
Building dependency tree
Updating FireMotD available updates count … E: Malformed line 1 in source list /etc/apt/sources.list.d/influxdb.list (dist parse)
E: The list of sources could not be read.ectories currently installed.)d and is no longer required:
Preparing to unpack …/python-ply_3.4-5_all.deb …

$ apt -y install apt-transport-https
Reading package lists… Done
Building dependency tree
Reading state information… Done
apt-transport-https is already the newest version.
The following package was automatically installed and is no longer required:
Use ‘apt-get autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2019-04-24_06:40:46_EDT [openHABian] Installing or upgrading to latest openHAB release (stable)…
$ wget -O openhab-key.asc
–2019-04-24 06:40:47--
Resolving (…
Connecting to (|… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [application/octet-stream]
Saving to: ‘openhab-key.asc’

openhab-key.asc [ <=> ] 3.12K --.-KB/s in 0.001s

2019-04-24 06:40:47 (2.60 MB/s) - ‘openhab-key.asc’ saved [3197]

$ apt-key add openhab-key.asc

$ apt update
E: Malformed line 1 in source list /etc/apt/sources.list.d/influxdb.list (dist parse)
E: The list of sources could not be read.

$ apt-get -y install openhab2=
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Version ‘’ for ‘openhab2’ was not found
FAILED (apt)

Can you tell me, how i can switch between milestone and snapshot in a non-openhabian-installation without the setup-menu-options?

Is there a list, which milestone is between which snapshots # ?

testing repo: Milestone builds
snapshot repo: Snapshot builds

There is only one Milestone for 2.5 yet, please watch the announcement section:

1 Like