openHAB 2.5.12 - Add-ons 'Error 500: Internal Server Error'

I have been successfully running openHAB 2.5.12 for the last couple of years, controlling Wemo lights, DSC security, NEST thermostat (until this past September), monitoring a PIC microcontroller connected to a non-contact liquid sensor and many other things.

The other day I wanted to look at adding another binding and I got the following error message:

‘Error 500: Internal Server Error’

I’ve spent a few days scouring the Internet and the forum looking for a solution and so far, I haven’t been able to find one. I’ve cleared the tmp. files and cleared the cache, but still get the same error.

All my REST connections work, except for the extensions. I get the following error;

x.x.x.x:8080/rest/extensions

‘SyntaxError: JSON.parse: end of data after property value in object at line 1 column 57343 of the JSON data’

I checked the location of the other JSON databases assuming that’s where the extensions database is stored, so I could check the file, but as most of you already know, it’s not there.

From my research, I believe the bindings are also stored in a local .KAR file, which is there. I renamed it and downloaded a fresh version of it. I then modified the config file to force openHAB to look locally for the bindings. It seemed to work, but then some of my bindings, like the DSC binding wouldn’t initialize.

Anyone come across this issue? If not, I would greatly appreciate any ideas of things I can try.

I did have a version 3 of OH running successfully, so I planned on migrating my things over to it. Seeing that 4 was released, I did an upgrade of the 3 to the latest version but it failed miserably…won’t even startup. So I will eventually do a fresh openhabian install of 4. In the meantime however, I’d like to keep 2.5.12 up and running.

[EDIT] I should also add, the 2.5.12 installation was done after the sunset of Bintray by installing v3.x and downgrading to 2.5.12.

Thanks!!

1 Like

Have exactly the same issue and found no solution yet.
Any ideas are appreciated.

1 Like

Bump.

Same issue, I feel like it started this week without any major change. help!

1 Like

same issue here ? has anyone news on that ? thanks

Anyone?