Openhab 2.5.5 docker container for Raspberry Pi/armhf

Hi, yesterday I have tried to update my Openhab Docker container from 2.5.0 to 2.5.5.
I use docker-compse, after starting with up -d an Error Message appeared:
“Pulling openhab (openhab/openhab:2.5.5-armhf-debian)…
ERROR: manifest for openhab/openhab:2.5.5-armhf-debian not found: manifest unknown: manifest unknown”

Has something changed? Do I have to build my own openhab Image for armhf? I have updated now to 2.5.4, this worked fine.

version: '2.2'

        image: "openhab/openhab:2.5.5-armhf-debian"
        restart: always
        network_mode: host
          - "/etc/localtime:/etc/localtime:ro"
          - "/etc/timezone:/etc/timezone:ro"
          - "/opt/openhab/addons:/openhab/addons"
          - "/opt/openhab/conf:/openhab/conf"
          - "/opt/openhab/userdata:/openhab/userdata"
          USER_ID: "999"
          GROUP_ID: "994"
          OPENHAB_HTTP_PORT: "8080"
          OPENHAB_HTTPS_PORT: "8443"
1 Like

Tags containing the architecture are no longer supported. It should work fine if you use 2.5.5-debian instead.

Thank you for your fast response. Now it works. Was there an announcementfor that?

No there was no announcement. The tags containing the architecture were deprecated ever since there are multi architecture manifests for the images. These tags were also removed from all examples. Since this is only the second call for help it might not be worth an announcement.

Ok,seems legit. Thank you for your help.