Openhab 2.5 Broadlink Bridge

Hello guys, I’ve a community friend for a 2 years almost just post from my friend user now.
Any way, I’ve been trying to look up in every topic here in the community forum, with no suscces.

I’ve issue found a bridge with Broadlink
At version 2.4 it’s worked greate I’ve been worked with a famous git, but now at 2.5 I’m lost!
If someone know any solution or any piece of info will be great.

Full version: openHAB 2.5.10-1 (Release Build)
Full Broadlink model: Broadlink RM Mini 3

Any info that I’ve been miss/not mantion here just ask me.

thanks for every one!

Hi, I have the latest version on 2.5 and the Broadlink beta version 16 (the last) and everything works perfect …
Let’s try to update the binding to the latest version … If It fails again you need to post some debug errors to better undestand the possible problems.


Not quite sure what you’re asking, but here’s the latest Broadlink binding:

Hi thank you so much for answering, You mean this git right?

What should I do after download the Zip file or the Jar File?

Yes, download the jar and replace the one you have in the addon folder

In my add on folder you can find only 1 file “openhab-addons-2.5.10.kar” and the Jar file I’ve been download from the githun have 4 folders , do I need to transfer those 4 folder to my Addon file in Openhab-sys?

if you only have the “openhab-addons-2.5.10.kar” leave it as it is, your broadlink binding is missing that’s the problem.
So just download the jar and put it in the addon folder as it is and should work

As I said … when I downloaded the jar file its have 4 folderes inside, I transfer them to the add on file and I still cant find the broadlink binding.
thanks and sorry for missunderstand you.

Don’t open the jar file, just move the whole file to the addons folder.

1 Like

I’ve done this, and I still can’t find the broadlink binding in the Paper UI, this is what I’m looking for am I right? I moved the .jar file to the AddOn file (I’ts have .jar in the end, but it’s a winrar file that inculde 4 folders inside)
I’ve moved the .jar (also winrar) to the add on folder and after reboot still nothing new in my paper UI binding.

Please post a screenshot of your addon folder content.
Restart OH2 should be enough in most of the case but sometimes you also need to clean the cache to make it working.


I’m also utterly confused about how to get OpenHAB to work with my Broadlink RM4, but I think I figured out this one:

That is because manually installed Add-ons are not shown under Bindings in UI. But when you then manually add a thing, it should be in the list of bindings there.

What I don’t understand, though, is why the Broadlink binding doesn’t show up in the add-ons repository (not even an old version). I read here that there are risks with installing an add-on via the .jar file because that method doesn’t consider dependencies. So it seems more advisable to install the add-on via the repo and then perhaps update it by copying the jar-file to the add-on folder. But how do I get the add-on installed via the repo?