openHAB 2.5 - Wemo Accounts compatability

Has anyone used the newly introduced “Wemo Accounts”? If so did your Wemo devices still work correctly with openHAB / openHAB 2.5? I have delayed registering with Wemo Accounts in fear that it would break openHAB-Wemo integration. On the other hand not moving to Wemo Accounts has already broken my IFTTT-Wemo integration.

Welcome to the community!

The Wemo account shouldn’t affect anything in OH since the binding is communicating with your Wemo devices locally. It would only be an issue if OH needed to go through the cloud, as is the case with IFTTT.

If your using the OH Alexa binding using Alexa routines to interact with the WeMo’s also would be an issue (cloud integration).

From what I read; you have to disable and re-enable the Alexa skill for the WeMo to reconnect the WeMo’s using the new user/pass option.

Best, Jay

Thank you for your quick response.

  1. I take your response to say that it shouldn’t be a problem in theory but you have not personally tried it. Is that correct?
  2. My concern was that the new Wemo Account functionality might disable some local connectivity as it implements the secure cloud connectivity. This FAQ is what left me with that feeling.

I am not using the Alexa or the Alexa binding or skills

I am using the Astro, HarmonyHub, hue, Network, NTP, Systeminfo, TP-Link Smart Home, and WeMo bindings.

I didn’t even know about it until I read your post. I’ve largely abandoned Wemos due to them being unreliable at the best of times, keeping only my Wemo Motion and Wemo Maker. Belkin discontinued both products and doesn’t update the firmware any more, so I rarely use the Wemo app.

So yes, theoretically it’s fine. The only impact should be if Belkin makes it impossible for openHAB to find the devices on your network via UPnP. However, your skepticism is warranted, since Belkin kind of sucks (in my opinion).

Let’s tag in the expert. @hmerk, would you have any concern about the Belkin’s new Wemo Accounts messing with openHAB integration?

Hehe, I also have retired my WeMo devices, just keeping them for debugging purpose.
I had a quick look at the FAQs regarding WeMo Account and don‘t see any issues coming.
As far as I understood, activating the WeMo account is limiting access in the original app only, no settings or firmware updates on the devices needed. They also describe the possibility to postpone activating the account, so atm, I don‘t expect limitations.

OK, I’ll give it a try in the next day or two and report back with the results on this thread.

Since you two have both retired your WeMo devices what do you now use instead? How are you talking to them from openHAB?

I use:

  • 4 WeMo Light Switches - they work well in my old 2 wire switch boxes and I use the press-and-hold functionality to cause them to toggle the other 3 switches when I hold any 1.
  • 8 or 9 of the WeMo Insight Smart Plugs because they also provide current monitoring which works well with my Sense energy monitor.

Best Regards,
Jamie Diamond

I have updated the app to version 1.25(777700) on IOS.
Created an account and verified it. No new firmware found for devices.
No issues with openhab controlling the wemo smart plug and motion sensor.


If they’re working fine then I wouldn’t change a thing. My issues stem more from the fact that I bought them in 2013 and found that the firmware/app/setup was still terrible six years later. The support provided in their Wemo community was terrible…users knew more than Belkin staff, who follow the time-honoured tradition of promising an answer and then never responding again. So by the time I got into openHAB, I had already jumped ship for TP-Link Kasa switches/plugs, which I find to be more reliable and less expensive (in Canada, at least).

If I were doing it over again, I’d use cheap Tuya-based switches flashed with Tasmota firmware and/or Z-Wave. Z-Wave devices cost more and can be frustrating at times, but when Z-Wave works it works very well. As for the Tuya devices, you can find them everywhere (including Costco), and they’re rock-solid with the Tasmota firmware. You just need a Raspberry Pi to flash them.

Saying all that, I think the Wemo switchs are some of the most aesthetically pleasing devices you can get. So they’ve got that going for them, at least.

1 Like

I have successfully converted to WeMo Accounts and openHAB WeMo integration/binding is still working just fine. No issues with openHAB controlling the 15 WeMo Insight Smart Plugs and 4 WeMo Light Switches.

  • Nothing changed from the openHAB perspective.

  • Re-authorization was required in both IFTTT and Google Home.

Thank you everybody who shared knowledge on what to expect here.

Well, I don’t know if it was related to the “upgrade” to WeMo Accounts but this happened shortly after the “upgrade” to WeMo Accounts. The reliability of my WeMo devices has gone way down. My openHAB frequently does not have/get correct status for WeMo Insight Smart Plugs and I will have to toggle the switch to get a WeMo Insight to respond. For instance to turn my dehumidifier on I will issue 3 .sendCommand. ON, wait a few milliseconds, OFF, wait a few more milliseconds, and ON again. Boom, works every time now. The other thing is I’ve had to create “shadow” switches, switch items not associated with any things, which I switch on and off in parallel with the actual WeMo switch. I check the status of that item in rules which need to query the state of the WeMo item. I will cross post part of this in [SOLVED] WeMo Reliability

I too am having issues since upgrading the firmware. When looking at tail, the log shows communication errors with all of my Wemo devices. Further, I get this error for each device: “Failed to get actual state for device ‘wemo:socket:Fm_Rm_Socket2’: Invalid URI host: null (authority:”

What openHAB and binding version ?

Thank you for your help! OpenHab 2.5.10 Release Build. The binding was installed via PaperUI and is wemo-binding-2.5.10. Everything was working well until the new Wemo “accounts” firmware update (I hadn’t updated in nearly a year but I bought some new devices and the app required the update). I updated on the 11th of November and the issues started immediately. After posting here I cleared the Openhab cache and that had no impact. I then removed the binding via PaperUI and reinstalled, the errors have disappeared for now. It’s been 6 hours so far.

Please enter

log:set TRACE org.openhab.binding.wemo

at karaf console, let the binding run and post your log when the error reoccurs.

Will do. The error popped up once last night, but has not errored out since. I started the Trace anyway and I’ll post when I have something.

Just a quick update, after uninstalling and reinstalling the binding, the error I was experiencing has not returned except for a few isolated incidences. If anything should change, I will post back. Thanks again for your quick response and willingness to help!