Openhab 2 RFXCOM error

So i am trying to get the rfxcom working but im getting some errors. First off it didnt automatically detect the transceiver so i added that manually. it did detect my origon scientific sensors and they work like they should. My issue is that im trying to send commandos from a lightning 4 socket set. There is a remote (im trying to duplicate the commands) and recievers that have different commands for on and off.
This is the key i tried to insert in the paper ui by manually configuring. It is from the remote and the code is what activates the socket

This is the massive errors that i get. If anyone knows how to set this up with examples id appreciate. It is the selection with crashes from rfxcom in a pastebin (i exceeded max length)

Hi Oliver,

Did you have any luck resolving this? If you could share more details - things, items, links etc, that would help anyone help you with what might not be working.


Hi @james_2_roberts As i could understand @pauli_anttila havent merged the lightning 4 stuff from the openhab 1 binding yet. Hopefully that will be available asap but i dont know. That would answer why it reads the origon scientific sensors but doesnt send the lightning 4 messages

Thanks @Oliver_Roed_Scholer - that’s worth knowing, and I assume is the same for Lighting5 which would explain the problems I describe in another thread.

Hos could I stay upto date with progress on the OH2 binding - I’d mis-read from the docs page that it was now supported -


Hi @james_2_roberts My best guess would be to ask the creator of the binding. As you can see in my other thread Openhab 2 with rfxcom 1 binding! (2 did not work at all)

I dont know the state but he does say

Lightning4 message seems to have some fixes and improvements on OH1 binding (committed February). I try to merge them soon.


@Oliver_Roed_Scholer, I can agree that there is problem with lightning4 messages.

Additional, there still bug in error messages printing. Your error message should be

Transmitting error: Invalid device id ‘5571921’

I don’t have Lightning4 devices my self, and in fact I have not implemented lightning4 message support. But I will take a look.

Hopefully soon

Hello there are news here? I use oh2 build 660 get this message when sending lightning4

2016-12-22 10:50:14.881 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'rfxcom:lighting4:usb0:5588229' to inbox.
2016-12-22 10:50:53.387 [ERROR] [binding.rfxcom.handler.RFXComHandler] - Transmitting error: Invalid device id '5588229'

Have tried again from hex to decimal

2016-12-22 10:53:43.990 [ERROR] [binding.rfxcom.handler.RFXComHandler] - Transmitting error: Invalid device id '89686569'

The support of Lighting4 can be discussed in the the following topic:

The problem is that it has been implemented that a pulse is expected to be added, it might be needed for output but is not accurate enough for to use it for input.