OpenHAB 3.0.2 HomeKit Integration Issues

I currently run OpenHAB version 3.0.2 as docker container, I cannot upgrade to 3.1.0 due to issues with one of my binding unfortunately. I’d like to get HomeKit integration working, however I experienced a few issues:

  1. I don’t see the QR code after installing and configuring the HomeKit Integration binding, I can find the OpenHAB bridge in Home app though. Is it a known issue in 3.0.2?
  2. When I tried to add the OpenHAB bridge in Home app, it just keep connecting and fails after a few minutes. Looks like HomeKit not able to make connection to the bridge. However in HAP discover I can see the OpenHAB bridge. No trace in log file as well. Any hint how to find the root cause of this issue?
    Thank you!

the QR code was introduced with 3.1. So have to upgrade your binding to see the QR code in the configuration.
I don’t know why you can’t add the bridge. Try to update (only) the homekit binding to >=3.1. This will show you the QR code and maybe fix your connection issue as well.

You need to run list | grep -i homekit via karaf console.
Get your Homekit ID and update the binding with:
update <ID>

Thanks a lot for the suggestion! I run OpenHAB as docker container and have no idea how to use Karaf console sadly.

Have you tried to start the Karaf console with this command? docker exec -ti CONTAINERNAME /openhab/runtime/bin/client

Yes I did, it complains cannot find /openhab folder…

Sorry, can’t help you with that…

Sure thanks anyways!