openHAB 3.0 Milestone 2 discussion

I doubt installing frontail references openhab2 by default. I think installing for openHABian does though.
They are 2 separate things. This thread title references openHAB, Just wanted to clarify.

Frontail i log viewer for openHAB.
After upgrade from OH2 to OH3 files have changed, but upgrading algorithm didn’t change this entry’s so we need to change them manually to view logs in OH3.

1 Like

only in openHABian which happens to install openHAB too.
Many of us use openHAB on other platforms.

Ok I understand. So how You view log files?

I go to the command line and either tail the file or use a text editor to view, but I plan on installing frontail separately.

Frontail is available as a docker container. That’s what I use.

1 Like

That is my plan. Is there any way to include it in the Main UI sidebar?

That’s a good question. Not sure if it’s possible or not. I actually have a cheap used monitor connected to a Pi that I leave on as a dedicated log monitor.

For serious debugging I tend to use less. I post important events oh to my own slack channel, so for light debugging I’ll look into slack and see what had happened or why something has happened. It’s easy to check on the phone.

Backup causes me a day of extra work. :-o You wonder how ?

I did the backup, reconnected the SSD to my RPI4. But instead of the USB2 port I used USB3.
That caused by 2.4G Wifi to collapse because of EM- Interference from USB3 near my router. That grounded all my ESP sensors.
Took me a while to figure that one out since it was intermittent and I did not touch any of those sensors.
With best regards from Murphy :wink:

I’m having problems with Frontail since upgrading from OH2.5 to 3.0.

I have modified the /usr/lib/node_modules/frontail/preset/openhab.json and /etc/systemd/system/frontail.service files to remove the ‘2’ from openhab paths.

I tried reloading systemctl daemon:

sudo systemctl daemon-reload

and then

sudo systemctl restart frontail.service

The log output is still mentioning a reference to openhab2:

journalctl -u frontail.service -b


Jan 06 13:39:43 openhab systemd[1]: Started Frontail.
Jan 06 13:39:44 openhab frontail[1015]: /usr/local/lib/node_modules/frontail/node_modules/configstore/index.js:65
Jan 06 13:39:44 openhab frontail[1015]:                         throw error;
Jan 06 13:39:44 openhab frontail[1015]:                         ^
Jan 06 13:39:44 openhab frontail[1015]: Error: EACCES: permission denied, mkdir '/var/lib/openhab2'
Jan 06 13:39:44 openhab frontail[1015]: You don't have access to this file.
Jan 06 13:39:44 openhab frontail[1015]:     at Object.mkdirSync (fs.js:757:3)
Jan 06 13:39:44 openhab frontail[1015]:     at make (/usr/local/lib/node_modules/frontail/node_modules/make-dir/index.js:61:12)
Jan 06 13:39:44 openhab frontail[1015]:     at make (/usr/local/lib/node_modules/frontail/node_modules/make-dir/index.js:68:5)
Jan 06 13:39:44 openhab frontail[1015]:     at make (/usr/local/lib/node_modules/frontail/node_modules/make-dir/index.js:68:5)
Jan 06 13:39:44 openhab frontail[1015]:     at Function.module.exports.sync (/usr/local/lib/node_modules/frontail/node_modules/make-dir/index.js:84:9)
Jan 06 13:39:44 openhab frontail[1015]:     at Configstore.set all [as all] (/usr/local/lib/node_modules/frontail/node_modules/configstore/index.js:56:12)
Jan 06 13:39:44 openhab frontail[1015]:     at Configstore.set (/usr/local/lib/node_modules/frontail/node_modules/configstore/index.js:88:12)
Jan 06 13:39:44 openhab frontail[1015]:     at new Stats (/usr/local/lib/node_modules/frontail/lib/stats.js:21:14)
Jan 06 13:39:44 openhab frontail[1015]:     at module.exports (/usr/local/lib/node_modules/frontail/lib/stats.js:67:37)
Jan 06 13:39:44 openhab frontail[1015]:     at Object.<anonymous> (/usr/local/lib/node_modules/frontail/index.js:29:15)
Jan 06 13:39:44 openhab systemd[1]: frontail.service: Main process exited, code=exited, status=1/FAILURE
Jan 06 13:39:44 openhab systemd[1]: frontail.service: Failed with result 'exit-code'.
Jan 06 13:39:44 openhab systemd[1]: frontail.service: Scheduled restart job, restart counter is at 3.
Jan 06 13:39:44 openhab systemd[1]: Stopped Frontail.
Jan 06 13:39:44 openhab systemd[1]: Started Frontail.
Jan 06 13:39:45 openhab frontail[1032]: /usr/local/lib/node_modules/frontail/node_modules/configstore/index.js:65

There is a reference to /var/lib/openhab2 but I can’t work out where this is configured.

Even a reboot hasn’t helped.

@ip-ua Did you get it working?

Do you use openhabian-config ?
In case the answer is a yes then make sure that you are on OH3 branch and deinstall frontail from within openhabian-config and install it again.

No this is a vanilla OH installation on Ubuntu on an Intel NUC.

Then this is really off topic for this thread and somewhat off topic for this forum. If you didn’t install Frontail through openHABian then probably the best we can offer is to go back through your notes to see how you installed that originally and re set it up with the new paths. We didn’t write Frontail.

There is another thread that solves this. It turns out to be an issue in /etc/passwd caused by the renaming of the openhab2 folders to openhab as part of the OH2 to OH3 changes.

Yes it working, but I do not remember how I fixed it…

I had the same problem on Gentoo that the export of JAVA_HOME did not work, the approach of @sidamos was also working for me. Thanks for the hints!

Same Error still in 3.1.0 M2

I tried to upgrade using openhab-config to use milestone 2. Once it’s upgraded the website does not function and the service has the following:
2021-04-05 11:13:44.733 [ERROR] [raf.deployer.features.osgi.Activator] - BundleContext is no longer valid
java.lang.IllegalStateException: BundleContext is no longer valid
at org.eclipse.osgi.internal.framework.BundleContextImpl.checkValid( ~[org.eclipse.osgi-3.12.100.jar:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl.registerService( ~[org.eclipse.osgi-3.12.100.jar:?]
at org.apache.karaf.util.tracker.BaseActivator.register( ~[bundleFile:?]
at org.apache.karaf.util.tracker.BaseActivator.register( ~[bundleFile:?]
at org.apache.karaf.deployer.features.osgi.Activator.access$300( ~[bundleFile:?]
at org.apache.karaf.deployer.features.osgi.Activator$DeploymentFinishedListener.deploymentEvent( [bundleFile:?]
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.callListeners( [bundleFile:?]
at org.apache.karaf.features.internal.service.Deployer.deploy( [bundleFile:?]
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision( [bundleFile:?]
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13( [bundleFile:?]
at [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
at java.util.concurrent.ThreadPoolExecutor$ [?:?]
at [?:?]

I downgraded to stable build and it all works.

Here’s my system details for the stable build configuration.

Hardware: PI 4
version: 3.0.1
buildString: Release Build
locale: en_US
configFolder: /etc/openhab
userdataFolder: /var/lib/openhab
logFolder: /var/log/openhab
javaVersion: 11.0.10
javaVendor: Azul Systems, Inc.
javaVendorVersion: Zulu11.45+27-CA
osName: Linux
osVersion: 5.10.17-v7l+
osArchitecture: arm
availableProcessors: 4
freeMemory: 34539576
totalMemory: 194969600

  • amazonechocontrol
  • irobot
  • network
  • onkyo
  • samsungtv
  • sonos
  • zwave
    ios: false
    android: false
    androidChrome: false
    desktop: true
    iphone: false
    ipod: false
    ipad: false
    edge: false
    ie: false
    firefox: false
    macos: false
    windows: true
    cordova: false
    phonegap: false
    electron: false
    nwjs: false
    webView: false
    webview: false
    standalone: false
    os: windows
    pixelRatio: 1.5
    prefersColorScheme: light
    isSecureContext: false
    locationbarVisible: true
    menubarVisible: true
    cookieEnabled: true
    deviceMemory: N/A
    hardwareConcurrency: 24
    language: en-US
    • en-US
    • en
      onLine: true
      platform: Win32
      width: 2560
      height: 1440
      colorDepth: 24
      touch: false
      pointerEvents: true
      observer: true
      passiveListener: true
      gestures: false
      intersectionObserver: true
      dark: light
      filled: true
      pageTransitionAnimation: default
      bars: filled
      homeNavbar: default
      homeBackground: default
      expandableCardAnimation: default
      userAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,
      like Gecko) Chrome/89.0.4389.114 Safari/537.36
      timestamp: 2021-04-05T15:34:33.059Z

There was some issue with M2 and dependencies, I forget what.
Fortunately M3 is now available.