Openhab 3.0 + TI CC2531 + zigbee-binding - Issue: No devices were discovered

Tags: #<Tag:0x00007f173a40bcc8> #<Tag:0x00007f173a40bb60> #<Tag:0x00007f173a40ba70>

Hi community,

I’m struggeling with zigbee binding and my CC2531 USB stick. I tested the scan with following ZigBee devices:

  • Tradfri Motion Sensor E1745
  • Tradfri Simple Switch/Dimmer (I/O)
  • Tradfri Bulb

All devices have been reset → (pressed before 4 x the pairing button).
But no luck no devices are being found in the INBOX of Openhab 3.0.1

Any other troubleshooting suggestions are appreciated!

flashed firmware on CC2531
CC2531ZNP-Prod.hex

dmesg out:
cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device

# list if the device has a port
ls -l /dev/serial/by-id
usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B0018E1ABA5-if00 -> …/…/ttyACM0

# testing the access to port ttyACM0
test -w /dev/ttyACM0 && echo success || echo failure
success

Output after reboot of raspberry pi 4 openhab debug logging:

2021-01-24 16:46:39.332 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - Starting ZigBeeDiscoveryService
2021-01-24 16:46:45.092 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to ‘127.0.0.1’ with clientid openhab
2021-01-24 16:46:45.388 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initializing ZigBee network [zigbee:coordinator_cc2531:Zigbee].
2021-01-24 16:46:45.390 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Channel 11
2021-01-24 16:46:45.392 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - PANID 65534
2021-01-24 16:46:45.394 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - EPANID 00124B0018E1ABA5
2021-01-24 16:46:45.398 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network Key 54328E85C171FCA551676EFAD23A9F8D
2021-01-24 16:46:45.399 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link Key 5A6967426565416C6C69616E63653039
2021-01-24 16:46:45.401 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Config: zigbee_initialise found, initializeNetwork=false
2021-01-24 16:46:45.413 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network Key String 54328E85C171FCA551676EFAD23A9F8D
2021-01-24 16:46:45.416 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network key final array 54328E85C171FCA551676EFAD23A9F8D
2021-01-24 16:46:45.427 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link Key String 5A6967426565416C6C69616E63653039
2021-01-24 16:46:45.430 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link key final array 5A6967426565416C6C69616E63653039
2021-01-24 16:46:45.432 [DEBUG] [.zigbee.cc2531.handler.CC2531Handler] - Initializing ZigBee CC2531 serial bridge handler.
2021-01-24 16:46:45.583 [DEBUG] [.zigbee.cc2531.handler.CC2531Handler] - ZigBee CC2531 Coordinator opening Port:’/dev/ttyACM0’ PAN:fffe, EPAN:00124B0018E1ABA5, Channel:11
2021-01-24 16:46:45.611 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Scheduling ZigBee start
2021-01-24 16:46:46.617 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - ZigBee network starting
2021-01-24 16:46:46.618 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initialising ZigBee coordinator
2021-01-24 16:46:46.762 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - null: networkStateUpdated called with state=INITIALISING
2021-01-24 16:46:46.841 [INFO ] [rnal.service.RemoteControllerService] - Using None interface
2021-01-24 16:46:46.945 [DEBUG] [ding.zigbee.internal.ZigBeeDataStore] - 00124B0018E1ABA5: ZigBee reading network state complete.
2021-01-24 16:46:46.980 [DEBUG] [nding.zigbee.serial.ZigBeeSerialPort] - Connecting to serial port [/dev/ttyACM0] at 38400 baud, flow control FLOWCONTROL_OUT_RTSCTS.
2021-01-24 16:46:47.295 [DEBUG] [nding.zigbee.serial.ZigBeeSerialPort] - Serial port [/dev/ttyACM0] is initialized.
2021-01-24 16:46:48.281 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Mesh Update Period 86400
2021-01-24 16:46:48.732 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - ZigBee Initialise: Previous device configuration was: channel=CHANNEL_11, PanID=10257, EPanId=00124B0018E1ABA5
2021-01-24 16:46:49.224 [INFO ] [.cc2531.network.ZigBeeNetworkManager] - Initialized ZigBee network with existing network state.
2021-01-24 16:46:49.325 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - ZigBee initialise done. channel=CHANNEL_11, PanId=10257 EPanId=00124B0018E1ABA5
2021-01-24 16:46:49.543 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - null: networkStateUpdated called with state=ONLINE
2021-01-24 16:46:49.895 [DEBUG] [ding.zigbee.internal.ZigBeeDataStore] - 00124B0018E1ABA5: ZigBee saving network state complete.

2021-01-24 16:48:53.261 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - Starting ZigBee scan for zigbee:coordinator_cc2531:Zigbee

Thing in OH3:

Zigbee LogViewer

I am not a Zigbee user but perhaps the log viewer can help while you wait.

Thanks, the logs don’t look like there are any issues, but nonetheless the scan doesn’t find any of my devices. It is my first implementation with the Zigbee Binding.
I also tried Zigbee2Mqtt without the openhab integrated binding, but it’s the same behavior only the topics of the bridge itself can be seen, but no devices will join.

When you tried it with zigbee2mqtt did you a) use the correct firmware on the cc2531 and b) ensure that permit_join was set to true in configuration.yaml?

I have both a Tradfri switch and bulb working perfectly fine with zigbee2mqtt, a cc2531, and integrated with openHAB via the MQTT Binding, though don’t have a motion sensor.

yes, I think I did:

homeassistant: false
permit_join: true
mqtt:
base_topic: zigbee2mqtt
server: ‘mqtt://localhost’
user: openhab
password: ‘my pwd’
client_id: Zigbee
disable_led: false
serial:
port: /dev/ttyACM0
advanced:
rtscts: false
log_level: debug
network_key: GENERATE

I tried both Fimwares for my CC2531 - Firmware CC2531

This is the Zigbee2Mqtt log, and when I reset the Ikea Motion sensor nothing new will come-up:

info  2021-01-25 10:01:10: Connected to MQTT server
info  2021-01-25 10:01:10: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
debug 2021-01-25 10:01:10: Received MQTT message on 'zigbee2mqtt/bridge/info' with data '{"commit":"07cdc9d","config":{"advanced":{"adapter_concurrent":null,"adapter_delay":null,"availability_blacklist":[],"availability_blocklist":[],"availability_passlist":[],"availability_timeout":0,"availability_whitelist":[],"cache_state":true,"cache_state_persistent":true,"cache_state_send_on_startup":true,"channel":11,"elapsed":false,"ext_pan_id":[221,221,221,221,221,221,221,221],"homeassistant_discovery_topic":"homeassistant","homeassistant_legacy_triggers":true,"homeassistant_status_topic":"hass/status","last_seen":"disable","legacy_api":true,"log_directory":"/opt/zigbee2mqtt/data/log/%TIMESTAMP%","log_file":"log.txt","log_level":"info","log_output":["console","file"],"log_rotation":true,"log_syslog":{},"pan_id":6754,"report":false,"rtscts":false,"soft_reset_timeout":0,"timestamp_format":"YYYY-MM-DD HH:mm:ss"},"ban":[],"blocklist":[],"client_id":"Zigbee","device_options":{},"devices":{},"disable_led":false,"experimental":{"output":"json"},"external_converters":[],"groups":{},"homeassistant":false,"map_options":{"graphviz":{"colors":{"fill":{"coordinator":"#e04e5d","enddevice":"#fff8ce","router":"#4ea3e0"},"font":{"coordinator":"#ffffff","enddevice":"#000000","router":"#ffffff"},"line":{"active":"#009900","inactive":"#994444"}}}},"mqtt":{"base_topic":"zigbee2mqtt","force_disable_retain":false,"include_device_information":false,"server":"mqtt://localhost","user":"openhab"},"passlist":[],"permit_join":true,"serial":{"disable_led":false,"port":"/dev/ttyACM0"},"whitelist":[]},"coordinator":{"meta":{"maintrel":3,"majorrel":2,"minorrel":6,"product":0,"revision":20190619,"transportrev":2},"type":"zStack12"},"log_level":"info","network":{"channel":11,"extended_pan_id":"0xdddddddddddddddd","pan_id":6754},"permit_join":true,"version":"1.17.0"}'
debug 2021-01-25 10:01:10: Received MQTT message on 'zigbee2mqtt/bridge/devices' with data '[{"definition":null,"endpoints":{"1":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"10":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"11":{"bindings":[],"clusters":{"input":["ssIasAce"],"output":["ssIasZone","ssIasWd"]},"configured_reportings":[]},"110":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"12":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"13":{"bindings":[],"clusters":{"input":["genOta"],"output":[]},"configured_reportings":[]},"2":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"242":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"3":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"4":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"47":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"5":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"6":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"8":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]}},"friendly_name":"Coordinator","ieee_address":"0x00124b0018e1aba5","interview_completed":true,"interviewing":false,"network_address":0,"supported":false,"type":"Coordinator"}]'
debug 2021-01-25 10:01:10: Received MQTT message on 'zigbee2mqtt/bridge/groups' with data '[]'
debug 2021-01-25 10:01:10: Received MQTT message on 'zigbee2mqtt/bridge/config' with data '{"commit":"07cdc9d","coordinator":{"meta":{"maintrel":3,"majorrel":2,"minorrel":6,"product":0,"revision":20190619,"transportrev":2},"type":"zStack12"},"log_level":"info","network":{"channel":11,"extendedPanID":"0xdddddddddddddddd","panID":6754},"permit_join":true,"version":"1.17.0"}'
info  2021-01-25 10:01:10: MQTT publish: topic 'zigbee2mqtt/bridge/info', payload '{"commit":"07cdc9d","config":{"advanced":{"adapter_concurrent":null,"adapter_delay":null,"availability_blacklist":[],"availability_blocklist":[],"availability_passlist":[],"availability_timeout":0,"availability_whitelist":[],"cache_state":true,"cache_state_persistent":true,"cache_state_send_on_startup":true,"channel":11,"elapsed":false,"ext_pan_id":[221,221,221,221,221,221,221,221],"homeassistant_discovery_topic":"homeassistant","homeassistant_legacy_triggers":true,"homeassistant_status_topic":"hass/status","last_seen":"disable","legacy_api":true,"log_directory":"/opt/zigbee2mqtt/data/log/%TIMESTAMP%","log_file":"log.txt","log_level":"debug","log_output":["console","file"],"log_rotation":true,"log_syslog":{},"pan_id":6754,"report":false,"soft_reset_timeout":0,"timestamp_format":"YYYY-MM-DD HH:mm:ss"},"ban":[],"blocklist":[],"client_id":"Zigbee","device_options":{},"devices":{},"disable_led":false,"experimental":{"output":"json"},"external_converters":[],"groups":{},"homeassistant":false,"map_options":{"graphviz":{"colors":{"fill":{"coordinator":"#e04e5d","enddevice":"#fff8ce","router":"#4ea3e0"},"font":{"coordinator":"#ffffff","enddevice":"#000000","router":"#ffffff"},"line":{"active":"#009900","inactive":"#994444"}}}},"mqtt":{"base_topic":"zigbee2mqtt","force_disable_retain":false,"include_device_information":false,"server":"mqtt://localhost","user":"openhab"},"passlist":[],"permit_join":true,"serial":{"disable_led":false,"port":"/dev/ttyACM0"},"whitelist":[]},"coordinator":{"meta":{"maintrel":3,"majorrel":2,"minorrel":6,"product":0,"revision":20190619,"transportrev":2},"type":"zStack12"},"log_level":"debug","network":{"channel":11,"extended_pan_id":"0xdddddddddddddddd","pan_id":6754},"permit_join":true,"version":"1.17.0"}'
info  2021-01-25 10:01:10: MQTT publish: topic 'zigbee2mqtt/bridge/devices', payload '[{"definition":null,"endpoints":{"1":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"10":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"11":{"bindings":[],"clusters":{"input":["ssIasAce"],"output":["ssIasZone","ssIasWd"]},"configured_reportings":[]},"110":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"12":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"13":{"bindings":[],"clusters":{"input":["genOta"],"output":[]},"configured_reportings":[]},"2":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"242":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"3":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"4":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"47":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"5":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"6":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]},"8":{"bindings":[],"clusters":{"input":[],"output":[]},"configured_reportings":[]}},"friendly_name":"Coordinator","ieee_address":"0x00124b0018e1aba5","interview_completed":true,"interviewing":false,"network_address":0,"supported":false,"type":"Coordinator"}]'
info  2021-01-25 10:01:10: MQTT publish: topic 'zigbee2mqtt/bridge/groups', payload '[]'
info  2021-01-25 10:01:10: MQTT publish: topic 'zigbee2mqtt/bridge/config', payload '{"commit":"07cdc9d","coordinator":{"meta":{"maintrel":3,"majorrel":2,"minorrel":6,"product":0,"revision":20190619,"transportrev":2},"type":"zStack12"},"log_level":"debug","network":{"channel":11,"extendedPanID":"0xdddddddddddddddd","panID":6754},"permit_join":true,"version":"1.17.0"}'

Personally I would definitely go down the zigbee2mqtt path since it offers a lot more flexibility and stability.
The stick you have, I replaced it in my Zigbee2mqtt with an Electrolama one, https://electrolama.com/projects/zig-a-zig-ah/ because it is virtually unlimited in number of devices, and it works so, so much better than those CC2531. Whatever you do, stop using this CC2531 thing asap…
So you say you used Zigbee2mqtt as well, and if you press the buttons on your devices to pair them, at least you should see in the zigbee2mqtt log that is is interviewing the devices, but from your explanation, you don’t see even that.
What I once had with this stick (in zigbee2mqtt, don’t know if behavior would be the same with binding), is that I had to pair my devices within 2 minutes after I plugged in the stick, then start zigbee2mqtt. It would simply refuse to pair any devices after a couple of minutes (this was a known issue I believe).
So if possible, and because zigbee2mqtt starts way faster than Openhab, can you :

  • Unplug the stick and stop any zigbee2mqtt/Openhab instances
  • Plug stick and immediately start zigbee2mqtt
  • Try to pair a device immediately (within a minute). Keep the device close to the stick (1m or so)
  • At a minimum, in the zigbee2mqtt log, you should see something like …device announced… or …interviewing… If not even that, then something is wrong with your stick (is it flashed by the way, with firmware because otherwise nothing much will happen indeed :slight_smile: )

Good luck!

Hi Ben,

I solved it a few minutes ago with Zigbee2Mqtt and with an Ikea Bulb as Router.
And after the bulb has joined I was also able to join the motion sensor from ikea.
Now I have to find out how to implement at least the motion sensor to my openhab.

Ikea Montion Sensor joined to Zigbee2Mqtt network… :wink:
Jan 25 11:06:26 raspberrypi node[8533]: Zigbee2MQTT:info 2021-01-25 11:06:26: MQTT publish: topic 'zigbee2mqtt/Bewegungsmelder1', payload '{"linkquality":31,"occupancy":true,"update":{"state":"idle"},"update_available":false}'

The only status that changes regularly at the motion sensor thing is the linkquality…

I am sure @chris would be interested in your experiences. He has paid business customers using those binding libraries with no major issue.

with this experimental configuration in the configuration.yaml

experimental:
  output: attribute

It is easy to implement the IKEA devices and their channels and map those to the items in openhab. No more transformation doings with JS or JSON. Each JSON Payload becomes a dedicated published channel like:

Bridge mqtt:broker:mosquitto “Mosquitto” [ host=“127.0.0.1”, secure=false, username=“openhab”, password=“pwd”, clientID=“openhab”, retainMessages=false]
{
Thing topic Bewegungsmelder1 “Bewegungmelder1” @ “Keller” {
Channels:
Type switch : occupancy “Bewegung” [ stateTopic=“zigbee2mqtt/Bewegungsmelder1/occupancy”, off=“false”, on=“true” ]
Type number : link “Link Qualität” [ stateTopic=“zigbee2mqtt/Bewegungsmelder1/linkquality”]
Type number : battery “Batterie” [ stateTopic=“zigbee2mqtt/Bewegungsmelder1/battery”]
}
}

But from my IKEA E1743 Tradfri ON/OFF Switch I get when I click:

Jan 25 14:02:00 raspberrypi node[3229]: Zigbee2MQTT:warn  2021-01-25 14:02:00: Received message from unsupported device with Zigbee model 'undefined' and manufacturer name 'undefined'
Jan 25 14:02:00 raspberrypi node[3229]: Zigbee2MQTT:warn  2021-01-25 14:02:00: Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html.
Jan 25 14:02:03 raspberrypi node[3229]: Zigbee2MQTT:warn  2021-01-25 14:02:03: Received message from unsupported device with Zigbee model 'undefined' and manufacturer name 'undefined'
Jan 25 14:02:03 raspberrypi node[3229]: Zigbee2MQTT:warn  2021-01-25 14:02:03: Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html.

And I’m sure that is really true.
For people just wanting integrated control and not always use the latest releases, the binding is great. I personally use MQTT since OH is only a part of my smart home (got Loxone and some other technologies as well)
While migrating from 2.5 to 3, or even experimenting with HomeAssistant, I have all operating in parallel and connected to the MQTT broker at the same time which is really easy to test. I even have HA an OH talk to each other using MQTT. It is more about the convenience of a common messaging system than about the quality of the Zigbee binding.
I let OH only control other systems, and not hardware directly because I run OH on Docker and let’s say that Docker and hardware often don’t play nice, especially when running on a QNAP with all different USB drivers than any other Linux systems :slight_smile:

Strange. Is it fully paired? I’m using the exact same switch with no issues.

I’m doing the same - it’s great to be able to ‘share’ hardware dongles between the two versions of openHAB via MQTT!

Would not worry about it. LQ goes from 10 to 250 and back all the time. Typically LQ increases in time also. Have devices operating perfectly for over a year with LQ of 10. As soon as they drop off all the time it becomes different of course.
Also remember that Zigbee and Wifi operate both on 2.4Ghz and can influence the LQ heavily. If devices are not far and still low LQ, try to find out the channels of Zigbee and Wifi 2.4, and assign different channels further apart for both. You can try putting zigbee on channel 25 (usually outside Wifi channels), but not all Zigbee devices support that. Note that changing the channel means pairing devices again.

Had some trouble after rebooting my Raspberry PI 4. All published topics report errors. At the end of the story I plug in the CC2531 into a self powered USB 3 Hub and all was fine again.

There are stories that USB3 interferes with Zigbee. For example if you plug in a SSD drive into a Raspberry into the USB3 port, you cannot plug a Zigbee stick like the CC2531 into the adjacent one.
Not sure if I fully believe all of that, but I did notice that using an extension cable for my stick, so it was 2m away from the USB plug, changed the quality and stability greatly. So always use an extension cord with your stick. Moving it to a separate hub also helps indeed.
https://www.intel.com/content/www/us/en/products/docs/io/universal-serial-bus/usb3-frequency-interference-paper.html.

These, and more tricks to improve stability are available from zigbee2mqtt, in case it helps some more:

1 Like

hello I’ve been working for two days, it just doesn’t connect. Where could I be wrong? Where are the places I should check? I would be glad if you could help.

Zigbee2MQTT:info 2021-02-20 14:40:26: Logging to console and directory: ‘/opt/zigbee2mqtt/data/log/2021-02-20.14-40-25’ filename: log.txt
Zigbee2MQTT:info 2021-02-20 14:40:26: Starting Zigbee2MQTT version 1.17.1 (commit #6484fee)
Zigbee2MQTT:info 2021-02-20 14:40:26: Starting zigbee-herdsman (0.13.59)
Zigbee2MQTT:error 2021-02-20 14:40:27: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-02-20 14:40:27: Failed to start zigbee
Zigbee2MQTT:error 2021-02-20 14:40:27: Exiting…
Zigbee2MQTT:error 2021-02-20 14:40:27: Error: Error while opening serialport ‘Error: Error Resource temporarily unavailable Cannot lock port’
at Znp. (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:136:32)
at Generator.next ()
at /opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:27:71
at new Promise ()
at __awaiter (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:23:12)
at SerialPort. (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:134:49)
at SerialPort._error (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/node_modules/@serialport/stream/lib/index.js:198:14)
at /opt/zigbee2mqtt/node_modules/zigbee-herdsman/node_modules/@serialport/stream/lib/index.js:242:12
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.17.1 start: node index.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zigbee2mqtt@1.17.1 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/openhabian/.npm/_logs/2021-02-20T11_40_27_189Z-debug.log

You should a) start a new thread and b) potentially ask over at zigbee2mqtt because the log you provide is from zigbee2mqtt, not openHAB, so you may not get much help here.