openHAB 3.4.5?

Hey all, I’ve been using openHAB 3 on a QNAP NAS vm. I’ve since moved to TrueNAS, but before I moved OH I ran the CLI backup. I built a new vm and wanted to make sure I ended up with OH3 instead of 4.0. (I wanted to make sure I restored a 3.x backup to a 3.x instance.) Doing a search led me to this: sudo apt-get install openhab=3.4.4-2. The install went well and the restore worked, but I couldn’t get a UI to render. On a hunch I checked what versions were available using ‘apt list -a openhab’. I figured the latest version of 3.x was the one to use so installed 3.4.5. After moving to 3.4.5 everything installed correctly and the restore worked great! I now have a working OH 3.x instance on a TrueNAS vm.

My question is about 3.4.5. Everything I see shows 3.4.4 as the latest version. Am I OK running 3.4.5? Is it a final 3.x hurrah, or is it not meant to be used? Everything is working (so far) so I assume it’s OK, but I don’t want to run into some weird issue because I used a release that wasn’t meant to be used.

Thanks in advance,


Yes, 3.4.5 is ok, 3.4.4 is the latest stable version before openHAB4.0 was stable, 3.4.5 is sort of backport from some bindings. See

for details.


It got its own announcement too: openHAB 3.4 has arrived! - #7 by Kai

Ah! I missed the announcement. Thank you for the information! Glad to know I’m in the clear. Once 4.x gets a few releases I’ll look into upgrading. (Who am I kidding, I didn’t update to 3.x until 4.0 was almost ready. Ha!)




It’s worth the effort :slight_smile: