openHAB 3.4 Release discussion

How to display it as an item?? I mean the start level?

Are you running Java 17? I believe 4.0-snapshot was just changed to drop support for Java 11.

I am on java 11. is there a reference somewhere about this change?
thanks for replying!

Raise minimum JDK version to 17 (#2994) · openhab/openhab-core@41ba3ff · GitHub and Raise minimum JDK version to 17 by J-N-K · Pull Request #2994 · openhab/openhab-core · GitHub.

1 Like

29 posts were split to a new topic: UoM default units and consequences

A post was merged into an existing topic: openHAB 4.0 SNAPSHOT discussion

just a few posts up. its because of - Java 17 needed. i upgraded to 17 and it started working but i think some bindings broke for me. so i reverted back to stable 3.4

1 Like

I need a little more help. I can’t figure it out. Do I need to go to each “Hue Item” I created and do this. Also, where on the Item screen do I enter this.

Folks, let’s hold off on the 4.0 snapshot issues until we can get a thread started for that. I don’t want to pollute this thread with issues unrealated to 3.4.

A new thread has been opened. Please report 4.0 snapshot problems here: openHAB 4.0 SNAPSHOT discussion

@BiloxiGeek, I’ll move your post over to there.


I had to look twice into the config, but just “2” steps for migrating to https:

  1. Make sure the bridge is set to https
  2. Make sure port is changed from 80 to 443



Somehow since the 3.4.0 update my Hue binding has significant delay. Does anyone else face this issue?

I get the following error after upgrading to 3.4: “ImportError: cannot import name Transformation”, triggered by the following import in my jython scripts:

from core.actions import Transformation

What do I need to change to make it work again?

@sucre I have the same issue. I don’t know what it is yet.
EDIT: It is a known issue, and here is the solution:


Thx a lot, that worked!

i updated to 3.4 and now i cant access:
Developer Tools
if i click on them nothing happend.
has anybody else the same problem?

it only works if i type the ipadress:port/setting in my browser.
in Openhab app they are also not accessable

No, I just checked. I can click on them all and it works. What browser are you using, has your startup finished, have you restarted your browser?

tryed a few times.
after i accesed the setting by ip:port/settings
everything worked.
so for now problem is solved, but its strange

Dear all,
same procedure as every half year, here’s my moderator’s request:

Please only post to this thread on issues specific to 3.4 code, i.e. issues that were introduced with 3.4 and didn’t exist before, that you can reproduce and confirm to be general issues with the code and not your installation.
Help us keep communication clean and effective. So for anything else, please open your own thread.
Thank you.

10 posts were split to a new topic: Setpoints and Drayton binding in 3.4

I upgraded to OH 3.4.0 this morning and had several messages indicating issues with shelly username/password. After 3 or 4 reboots those messages dissapeared though.
All 30+ shellies working fine now on OH 3.4.0…