Openhab 3 & Cloud Connector

  • Platform information:
    • Hardware: Raspberry Pi 3
    • OS: Openhabian
    • Java Runtime Environment: latest
    • openHAB version: 3
  • Issue of the topic: connect to cloud connecter (myOpenhab)

Hi All,

Just installed the Openhab 3 version on my Raspberry.
(just a clean installation).

now I have already some items/things in the configuration.
before I transfer every thing to Openhab 3, I just want the basic setup running.

Now I want to try to connect the Openhab 3 to myOpenhab and try to find the UUID and SECRET.
It seems that you can’t get the UUID and SECRET in the same way as it was with OpenHab 2.

(at least as I try to search for /var/lib/openhab2/uuid (or /var/lib/openhab3/uuid and /var/lib/openhab2/openhabcloud/secret I don’t find anything).

Does anyone already succeed in doing this?

Best Regards,

Piros

I believe openhab2 was dropped, when you are browsing folders in Linux try the following:

ls /var/lib/

Should report back a /var/lib/openhab/ folder

Thanks. the solution was:

SSH into your OpenHab server and execute the following command to get the UUID.

cat /var/lib/openhab/uuid ; echo

Execute the following command to get the Secret

cat /var/lib/openhab/openhabcloud/secret ; echo

so indeed replace openhab2 into openhab.

4 Likes

OH 3 folders are just “openhab”, not “openhab2”. Try looking in /var/lib/openhab/uuid.

That looks like a place that needs to be updated in the docs.

Hello,
Is it possible to show the new pages of OH3 on the phone app?

If not already implemented, support is in work.

I don’t know if it is possible to implement it actually. Is it needed to make any configuration?

Has anyone tried to show the panels on the phone or tablet app?

Very helpful. Easier is it not to make.

Cheers

Nice, thanks that was helpful.

Cheers

Hi folks,
i’m looking for the uuid and the secret, too.
In my case a using openhab 3 within docker on a Synology NAS.
I mounted the userdata and conf folder to my windows pc but there is no uuid or openhabcloud directroy within there. Also there is no openhab directory within /var/lib/ on the host. I have tried out to looking for the file (find . -name uuid) without any success.
Is it nessesary to add a binding or thing after installation of the misc through the web page?
Or may be the openhab instance is not allowed to create the directory?
Thx for your advise.
Sascha

In the image the userdata folder is /openhab/userdata. But if you’ve mounted a folder from your host to that location you will see the contents of that folder from that folder just as easily from inside the container. All I can offer in terms of debugging is it works for me running in Docker.

The folders are not there. I deinstalled the misc and install it again:

There is an error message within the log:

Failed installing ‘openhab-misc-openhabcloud’: Permission denied

All the installations of the bindings works fine. I’m not the linux/docker guru :frowning:

Sascha

If it’s permission denied then the file permissions on the openhab folders are not such that the user can write to them.

I don’t use Synology so you’ll have to find someone who does to make this work. But the root problem is on the Synology and with file permissions.

Hi agian,
i’ve cheked once agian that the cifs file permission on the share (NAS) are set correctly. I’ve also cheked that i mentioned the correct uid of the Synology user within the docker environment variables (and also the group id).

I’ve cleared the OH cache and restarted the docker image several times without success.

After that, i started with a clean docker image of OH3. The image a used before was a result of an update process from OH2.5.5 to OH3. After installation of the openhabcloud misc, the uuid and the secret appears emediately and it works.

So, thx for the support.

Sascha