Openhab 3: Error creating rules or scripts using blocky

  • Platform information:
    • Hardware: Raspberry 3b+
    • OS: Raspbian
    • Java Runtime Environment: 11
    • openHAB version: 3.0.0 (Release)
  • Issue of the topic: Error creating rules or scripts.

Seems like my OpenHab’s rules and blocky scripts functionality is broken. This error happens when I try to save a rule or I try to open the Blocky editor. I’m using the latest Openhab build. I previously had the 2.5.x version, but I installed the new version following the official instructions.

The error shown in the browser’s developer network tools console: Creation of the rule is refused: null

Should I completely remove Openhab and make a fresh installation?

Video of the error: Openhab Error - YouTube

What’s in openHAB.log when the error occurs?

Thats’s the only line in the logs.
The solution for this issue can be found here: [SOLVED] OH3 Issue: unable to create rules, scripts, schedules
I created a PR for improved logging: #2054 improved errorlogging for adding rules by bergvandenp · Pull Request #2053 · openhab/openhab-core · GitHub


As @bergvandenp says, that’s the only line in the logs. The solution explained below worked for me!