Openhab 3 Homematic Items only turn on, not off

Hey together,

try to migrate from OH2.4 to 3. (with homegear and some Homematic things)
1st try: Upgrade via openhabian-config
2nd try: New clean openhab 3 installation with /etc/homegear and sql.db copied from the old system

Both ways worked. In the first way all Homemetic things were migrated in the second way i had to add the new homematic bridge, then all the things were in the inbox.

In both way i encountered the same problem:
I am able to switch ON a device (Light switch or plug) but i can´t turn it OFF.
It´s possible to switch on and off via Homematic konfigurator or manually. In Openhab the item state is not updated.

Any Idea???

Nice greetings

Christian

Hi @all,
i have the same Problem. In the events.log i can see:
ThenToggle the Item Switch to ON in the log: Item ‘name of the siwtch’ received command ON
Then I Toggle to OFF there no entry in the log.

Nice greetings
Frank

Ich have the same problem too. Thats a big bug.

I have tested it with a plug (HM-LC-Sw1-Pl-DN-R1) and I could turn it on and off without any problems.

First of all: where did you try to switch off and on? In Basic UI or in the new Main UI?

Probably this issue is a general problem, see: Switch OFF Command stuck · Issue #731 · openhab/openhab-webui · GitHub

What kind of devices are having problems?

I also need some more information: can you please turn on TRACE log mode for the Homematic binding. Then please toggle the switch ON and OFF and attach the relevant part of openhab.log here.

Are you all using Homegear or also a “normal” CCU?

Hi, i made a clean openhab3 configuration and have quite some Homematic things. I cannot confirm your bug, here the switches work as expected. I hope you find the route cause.

Tried to switch the item via Openhab3 Web UI -> Einstellungen-> Items -> State …
The problem appeared with a wall actor ( HM-LC-Sw1PBU-FM) an a plug (HM-LC-Sw1-Pl-DN-R1)

In the Homegear Log, only the ON Command appears:
01/01/21 11:43:38.999 RPC Server (Port 2001): Info: Client number 42 is calling RPC method: setValue (2) Parameters:
(String) OEQ0332967:1
(String) STATE
(Boolean) 1

Please read my last post. This problem could be related to a general problem in OH 3. If the log contains no entry for the OFF command, then I would assume that it caused by the UI and not “OFF” event is sent to the binding.

As you are using Homegear, you have to prefix the item ids with HG as before (don’t know whether could cause an error like this).

But without a TRACE log I can’t give more advice.

1 Like

I have the same problem with a clean install of openhab3 with all of my items (zigbee2mqtt and tp-ling binding). Additionally habpanel can`t connect to the rest api. If I disable the REST auth bundle in karaf console (bundle:stop org.openhab.core.io.rest.auth) everything works instantly! I am confused that only a few people have the problem, I even did a second clean install with the same result.

I have the same issue on OH3, running on Kubernetes. Not a fresh install, I upgraded via docker image and kept the conf, userdata and addons(empty) folder via PersistentVolume.
Only binding I am currently using is the Hue Bindung with Original Hue Bridge and Deconz Stick / Phoscon Gateway.
Turning on the lights with both technologies (Hue/Deconz) works from the interface, turning them off does not.
One of my pre-existing rule does seem to work, however. It uses .sendCommand(OFF) on an original Hue-item.

I did not have time for further diagnosis but as of now my guess is a UI issue.

[Update: reading the older post of MHerbst, this does indeed seem to be exactly the issue on github. ]