OpenHAB 3: Item "Analyse" doesen't work


I’m using OpenHAB 3 and I’ve definded this item:

As you can see, it’s online etc.

But when I click on “Analyse” (on any item), I do not have any statistic data:

This is my item:

Any idea what’s the prolblem?

Have you changed any of the persistence settings (ie. a custom rrd4j.cfg) as that could stop the data being recorded. Also, try opening it, waiting a bit, closing it and then opening again and waiting, if this works than there is a performance issue and will be harder to diagnose.

Hey @Sunny
Thanks for your replay!

That’s the one I have:
Haven’t changed anything. I’ve upgraded from OpenHAB2, but I never really used it. I started with all items/things etc from scratch.

I’ve checked rrd4j.cfg, nothing in there. Other files seems to be not edited as well.

I tried it with opening/closing/opening, didn’t work. Thanks anyway.
I’m using a NUC, I guess performance shouldn’t be an issue.

May have inherited the system “default persistence” setting. Check that points to rrd4j.

1 Like

Just to summarize what has been said and provide some details.

A brand new instance of OH 3 will come preinstalled with rrd4j. By default (i.e. when there is no rrd4j.persist file) rrd4j will save all supported Items on every change and every minute (as required by rrd4j) and restoreOnStartup. I believe rrd4j will also be set as the default persistence.

However, if you’ve upgraded from OH 2, rrd4j may not be installed, may have an rrd4j.persist file that prevents it from saving all the Items, or it may not be set as the default. Any one of these can cause the Analyse function not to work. One common trip up is setting MapDB to be the default persistence. The charts are generated using the default persistence and MapDB only saves one value so can’t produce charts.


@rossko57 Yes, this might be the problem. Where can I check that?

/etc/openhab/services/rrd4j.cfg is empty

But /etc/openhab/persistence/rrd4j.persist contains:

Does this look ok?

I’ve installed under “Add-on” -> “Persistence” the “MapDB Persistence” and under “System Services” “Persistence” MapDB. After that, I’ve waited a couple min and checked the item and:

it’s alive! :star_struck:

I switchted back to rrd4j, but again no values :cry:

I don’t know. Is your Item a member of Temperature or Weather_Chart? If not it’s not being saved using that .persist file.

1 Like

Thanks, @rlkoshak you’ve been right!
It was the old (and unused) file /etc/openhab/persistence/rrd4j.persist
I renamed it to old and restarted openhab and now it works!

1 Like

This answer helped me. I had a similar problem. On checking I found rrd4j was installed but not set as default. One click solved the problem!