OpenHab 3 MainUI Admin Login Black Website

After 1 day working with OpenHab 3 i can not login at the MainUI.
Tried it on different devices but always the same.
I use a clean openhabian 1.6.2
Everything else is working fine, no errors in the log.

When i refresh the page after a login try: http://ip:8080 -> i am not logged in.

Has something like that already happened to anyone?

i solved it by cleaning the cache. Now it works again like intended.

1 Like

hm, I get this every day now.

I have to clean both:


One of them is not enough.

Hm, since that one time, its working. Do you log out after working as admin, because i never log out. Maybe you can try it and report back?

Or you can use:

sudo openhab-cli clean-cache

I was trying to see if I could find something, so I used the file delete method manually.

I have not tried log out… :slight_smile:

This seems to happen when I restart OpenHab.
I do some work on my Things, trying to clean up,
so could happen when restarting zwave binding also…

I have the same issue at the moment. New installation of openhabian 1.6.2 with openhab 3.1.0-SNAPSHOT - Build #2147.
I get this in the log:

2021-01-18 18:12:38.110 [INFO ] [rg.apache.cxf.jaxrs.utils.JAXRSUtils] - Resource class does not support HEAD http method, method listen supporting GET http method will be invoked

Without logging in, everything is fine. when I log in, I only get a blang page. Although openhab is set to darkmode, the pages are white.

I did a restart now and it works now. Let’s see how long. The entry in th logs appears also, when it works.

See here: OH3 MainUI, Browser shows blank page after login - #8 by ysc

You need to bump up the snapshot you are running for the fix