openHAB 3 migration tr064 binding

Hey community,

i try to migrate from openHAB 2.5 to openHAB 3.0 and i have a problem with the tr064 binding.
Old Version of the binding works fine with openHAB 2, but this is Binding Version 1 with a .cfg-file and this is not working with the new openHAB 3.

I installed the binding tr064 on openHAB3 and tried to register my fritzbox as a thing.
This is the content of the tr064.things-file:

Bridge tr064:fritzbox:fritzbox “FritzBox” [ host=“192.168.188.1”, refresh=60, user=“openhab”, password=“xxx”] {}

I can see the thing and seems to be good, but an error is displayed.

This is the AVM Documentation:
https://avm.de/fileadmin/user_upload…irst_steps.pdf
If a user is not authenticated, 401 (“Unauthorized”) will be returned.
If a user is authenticated but has not the needed rights, 606 (“Action not authorized”) will be returned.

But! I got the same fault message with a wrong password! The password doesn’t matter.

How can it be fixed? Tanks in advance! :slight_smile:

Regards
chris

Did you try the TR064 binding?

I think so:

Sorry for the stupid question but sometimes it’s better to start from the basics: have you tried to re-input the frizbox password in the UI configuration?
It seems that by default every time there is a username and password the UI just put the openhab credentials.

Sorry, I should have read more of the the OP.

Thanks for your replies!

Okay, a new try.
I deleted the things-file and added a new Thing in the UI.
Same error. I double checked the credentials with the fritzbox NAS. I had a connection to the NAS.

I dont know.

Do you have a special user for that and is that user allowed to access TR064?

I have created a special user that has the following access settings:

Yes I did, look:

Generally i would say that this looks ok from configuration side, so unfortunately nothing we can help on.
So i would suggest to open an issue on github or search for the problem over there.

Did you try it with different different ports with http or https?
Did you try it with fritz.box or just with the ip adress? Do you have a pi-Hole running?

I had some troubles with it I had to configure the following stuff:

Perhaps it can help you.

***Update:
My binding was offline when I stop the conditional forwarding on my pi-Hole. There some issue with the fritz.box adress. Perhaps for all, who using a pi-hole set the conditional forwarding for you FritzBox.


And if you are interested here is some manual version:

I know it is recommended to use click and collect but I like to stay in the text mode.

Best,
Max

Is your FritzBox reachable as fritz.box e.g. by ping?
If not, that might be the issue. At least I ran into that bug. I think it’s already fixed in the code but after 3.0 has been released.

Now its working!

I deleted the Docker image and the mounts.
Then I installed everything again (3.10 snapshot) including the bindings.

After that I took the conf folder from my backup to the new instance.
The status changed to online and the information about serial and so on were read from the fritzbox.

Thanks to all!!

1 Like

Hi folks,
i also installed the tr064 binding in OH3. Ist was already running within OH2.5, but now i recognized an issue like u.

With the main (dslf-config) fritz user i received the follwoing error:

I tryed out a dedicated openhab user with the same result.
Sometimes - when i recreate the thing (over UI) - the following error appears:
image

I seen within my old .cfg file from the OH2.5 environment, that i used a http:// instead of an https:// connection. I think it is no longer possible to switch back to unencrypted in OH3?!
So i checked my TLS certificate of the fritzbox and recognized, that there is no keyusage, extended key usage and the wrong name. I fixed this with openssl without success. May be it is nessesary to put the self-signed certificate of the fritzbox within the trusted store of OH? Is someone familar with this?

Within the openhab.log the following message appears:

[ERROR] [com.sun.xml.messaging.saaj.soap ] - SAAJ0511: Unable to create envelope from given source

If someone have an advise for me…

Thx, Sascha

OMG,
a reboot of OH3 fixed it…

1 Like