OpenHAB 3 TCP binding

Hello all,
I’m also interested in the TCP/UDP binding.
As I see in this community thread some users use it in OH3.

From where do you got the executable .jar file? Have you copied it to the “addons” folder of the OH3 installation?

Thanks in advance!

Hi, I do not think there is a binding available for OH3, Lucas uses Node Red as a workaround

I’ve got a Mobotix T24 as door station.
In OH2, I’ve configure it to send a TCP command to launch a DingDong playsound command in openHAB.Today, I don’t know how to integrate it with OH3 … So I also requesting the TCP binding :slight_smile:

1 Like

I also used TCP and since the update to OH3 nothing works anymore …
I go back to OH2 forced and forced

Thanks for sharing. I’ve checked my configuration against yours and it looks the same but it’s not working for me.

The inbound is fine; if I trigger a command from a PuTTY connection, NodeRed and OpenHAB are getting the response but for the life of me, I can’t get a change in the outbound item to send the string to the device, even though the debug message shows what the TCP node should have received.

I noticed that using your method, NodeRed creates two connections to the device, one for the Tx and one for the Rx. as I’ve limited my device to two connections (for OpenHAB and PuTTY), it was a problem so I’m using the 2-way TCP node. I also tried separating the inbound and outbound items but still no luck.

Thanks again for the NodeRed solution; I’m guessing it’s something about my device.

Roll on an integrated TCP Binding!


I’ve interest in the tcp binding for this:

Best Regards,

I’ve opened an issue on github on posted a 50 USD bounty for developing a TCP-binding for OH3, see:
OH3 TCP-Binding 50 USD bounty

In case there are more users “really” interested in such binding please feel free to join me and add an additional bounty on OH3 TCP-Binding 50 USD bounty.

Hopefully with that incentive we’ll find a friendly developer who’s knowledgeable enough and willing to help with such binding (I’d do it myself if I know how unfortunately I don’t know how).

As it appears to me: help is on its way.
As far as I understand there’s a chance it might be included as of Rel 3.1.1 milestone - see:
TCP Binding for OH3
for detail.


That would be great.
I also need the TCP binding!!

It seems the binding is already coded. Any hints on when it will be available?

it seems that the TCP binding (at least the one syntacrsc was referring to) is not going to be included in OH3:

Too bad. Does anyone know why?

As others this is the remaining functionality stopping progress to OH3
Ive added the jar files, created a thing with the binding but cannot get a udp rely to work. This was a simple task with OH2 and so useful.
Is it possible some further guidance could be provided.

Switch Relayt "wall plug" (All) { channel=">[ON:] >[OFF:]" }

I have not read the binding documentation, but at first sight your item is missing any binding info after the channel keyword.

You want to use the binding with OH3 ?
Where did you get the jar file from ? I am not aware of that there is a TCP binding for OH3 at least it is not available in the documentation.

actually that was the wrong item.
The switch item in OH2 is

Switch Solar_switch "wall plug" (All) { udp=">[ON:] >[OFF:]" }

I changed it to channel to try to link to the thing and channel but the thing and channel remain unitialised
this is OH3

UID: tcpudp:client:91607768db
label: TCP/UDP Client
thingTypeUID: tcpudp:client
  protocol: UDP
  delay: 0
  port: 6723
  refresh: 30
  timeout: 3000
  bufferSize: 2048
  - id: thisrelay
    channelTypeUID: tcpudp:switch
    label: thisrelay
    description: ""
      onValue: "12"
      offValue: "22"

There is one under development, but not released yet AFAIK.

Have you not used channels with Items before? You would configure the channel in the Thing definition, as you seem to have already done, and then if you’re not using the UI tolink then you would give the target channel’s UID for the Item
Switch Solar_switch "wall plug" { channel = "tcpudp:client:91607768db:thisrelay" }
or something like

channels not really yet, as all still in OH2.5 which was migrated from OH1 originally.
I think the issue lies earlier on as the thing and channel are not initialized.

The back up plan is the exec binding via bash script.

This is for sending, right? And because there isn’t even a linked Item you’ve never tried to send anything. What’s to initialize?

This is an unsupported experimental binding. You might be better off taking more conventional first steps with OH3

in things it doesnt say online for the binding.
I use lan udp relays for all sorts of things from boiler control to alarms, so it is essential for my OH setup. If it cant be done right now, will stay with OH2 for a while

the issue was I needed to use the 3.2.0 version of the Jar file.
it works fine now thanks to j_N_K for providing