openHAB 4.0 Milestone discussion

I have the same problem with marketplace after upgrading. I have a relatively basic setup and I don’t have any bindings in the addons folder. I spun up a fresh M1 VM which worked fine until I restored my backup at which point the marketplace disappeared again.

Can you elaborate on what “you might need to go into $OH_USERDATA/jsondb/org.openhab.marketplace.json” means? Delete the file, delete the content in the file or modify the file?

Yes, after backing up delete that file and any backups of that file under the backups folder.

1 Like

I tried adding the Vizio binding this morning and am getting errors while using the console commands for pairing with the TV:

openhab> openhab:vizio vizio:vizio_tv:foo start_pairing openHAB                                                     
Error! Unable to start pairing process.
Exception was: Error executing vizio PUT command, URL: PKIX path building failed: unable to find valid certification path to requested target

The TV is using a self signed cert.

Created defect [vizio] Unable to pair with TV · Issue #14621 · openhab/openhab-addons · GitHub

Does the mihome binding work in 4.0? I see this:

 [WARN ] [core.thing.internal.ThingManagerImpl] - Channel types or config descriptions for thing 'mihome:gateway:7811dcb9c722' are missing in the respective registry for more than 120s. This should be fixed in the binding.
 [WARN ] [core.thing.internal.ThingManagerImpl] - Failed to normalize configuration for thing 'mihome:gateway:7811dcb9c722': {thing/channel=Type description for {0} not found although we checked the presence before.}

I still use Jython and I see the same issue. What do we lose by not having the directory trigger?

I need to work on porting to JS asap.

I guess not very much, I never used the directory trigger, although thera are some uses cases for it. It allows to trigger rules based on changes in local directories, e.g. added files.

A workaround would be to use an external script to monitor directories, e.g. using systemd Path Units and trigger an item via REST.

Maybe this is the way to gi, but I never liked JS. I am still hoping that someday Python rules will be supported via GraalVM. Before migrating to JS I will have a look at HABApp.

jRuby is also an excellent option.


Jruby doesn’t work on M1. The fix just got merged yesterday so it should be in the next snapshot.

Jruby has directory change trigger if you happen to need it. It supports OpenHAB 3.4.x and 4.0 (using the next snapshot build #3378 or later)


I upgraded to M1 and Homekit stopped working. So I deleted the bridge and tried to add it again, but it says “Accessory Already Added”. I fixed this in the past by uninstalling Homekit and clearing pairings, but I no longer this option in the UI. Any help would be appreciated.

I just upgraded from 3.4 to 4.0M1 and it seems none of my bindings work, which makes the system kinda unusable. Haven’t seen anyone above with this problem, so I’m asking if anyone knows what goes wrong? Pasting the relevant part of the log:

2023-03-19 09:55:55.913 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': Error:
        Error downloading mvn:org.eclipse.jetty.websocket/websocket-servlet/9.4.50.v20221201
        Error downloading mvn:org.eclipse.jetty.websocket/websocket-server/9.4.50.v20221201
2023-03-19 09:55:56.534 [INFO ] [.core.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2023-03-19 09:56:04.002 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.
2023-03-19 09:56:07.160 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-robonect, openhab-binding-networkupstools, openha
b-voice-voicerss, openhab-binding-exec, openhab-binding-mail, openhab-persistence-jdbc-mariadb, openhab-binding-tibber, openhab-binding-pushover, openhab-bin
ding-sonos, openhab-transformation-regex, openhab-binding-zwave, openhab-ui-basic, openhab-binding-tellstick, openhab-binding-systeminfo': Error:
        Error downloading mvn:io.netty/netty-transport-native-kqueue/4.1.72.Final
        Error downloading mvn:io.netty/netty-handler-proxy/4.1.72.Final
        Error downloading mvn:io.netty/netty-handler/4.1.72.Final
        Error downloading mvn:io.netty/netty-codec/4.1.72.Final
        Error downloading mvn:io.netty/netty-common/4.1.72.Final
        Error downloading mvn:io.netty/netty-codec-mqtt/4.1.72.Final
        Error downloading mvn:io.netty/netty-transport/4.1.72.Final
        Error downloading mvn:io.netty/netty-codec-http2/4.1.72.Final
        Error downloading mvn:io.netty/netty-transport-native-unix-common/4.1.72.Final
        Error downloading mvn:io.netty/netty-transport-native-epoll/4.1.72.Final
        Error downloading mvn:io.netty/netty-codec-socks/4.1.72.Final
        Error downloading mvn:io.netty/netty-tcnative-classes/2.0.46.Final
        Error downloading mvn:io.netty/netty-codec-http/4.1.72.Final
        Error downloading mvn:io.netty/netty-buffer/4.1.72.Final
        Error downloading mvn:io.netty/netty-resolver/4.1.72.Final
        Error downloading mvn:io.netty/netty-transport-classes-epoll/4.1.72.Final

Anyone knows what goes wrong?

This is on Debian 11.6 running zulu openjdk 17.0.6 aarch64 and the official OH packages from

When is the next milestone build planned?

My guess is about 1 month from the previous milestone. Snapshots are usually pretty stable to use too.

If you use Marketplace add-ons try removing those. Especially KAR based add-ons can mess up dependency resolution.

Nope, I’m only using “normal” addons included in the distro. These are the addons I have installed:

Network UPS Tools
System Info

I have currently reverted to 3.4.

Clear your cache. I had similar issues.

1 Like

Ah, of course! Why didn’t I think of that! I’ll try that and report back!

A little concerned about the memory use of OH4.0M1. I’m probably going to have to revert back because this is way beyond my skills, but thought I should report. I have very basic Rpi3b with zwave, mail and astro bindings. 29 things, 84 items, 1 page, 25 rules (DSL). Zram is installed. It is a remote system for my Rpi4 that has all the rules and additional bindings, pages, etc. I use this system_sensors tool to report. It was very stable prior to OH4.0M1 (only last 4 days on OH3.4 shown), then shows a steady rise over time with OH4M1 and then crashed 8 days later. The crash report is attached (it is too much information for me).

hs_err_pid7310.log (217.1 KB)

Only zwave, astro and mail? No rules?

I’ll add that (25 rules), most are on the Rpi4.

But no rules on the system that runs OH4.M1?