openHAB 4.2 Release Discussion

Solution: open the about:support page and click twice on “clean up Firefox”

I have the exact same situation here. Interface is there, but all the things are dead. Any way to go back to 4.1.3?

Running in docker, if it helps.

have entered the following in docker-compose.yml

image: openhab/openhab:4.1.3

This works for me again. This sets the image to 4.1.3.

That gave life back to the installation. Seems like some sort of network issue though. I have issues with my VPN connection to the site, need to investigate when physically on site.

Well. Unfortunately, I thought the same thing and then went into the container at the cli. But the network was fully accessible there. All DNS names were resolved and the pings worked without any problems. In addition, the 4.1.3 works without any problems.

Hi,
since OH 4.2 the BasicUI discards all my settings (light design, 2 columns instead 3) after every browser restart.
After restart there is the setting with dark mode and 3 columns again.

Is that correct or an error with the update?

After upgrade today my testsystem from 4.1.3 to 4.2 some of my shelly’s will not work anymore:
@markus7017 : Please see, that the Shelly’s which have a extentation Module attached will NOT work:




Everything has been work file with the DEV binding from shelly 4.2 for some month. So not very nice, that the DEV binding has worked, and now the official has an issue.
Please have a look on it @markus7017

Thanks in advanced.

**UPDATE: **

by deleteting the things an recreate on my dev system the issue was gone.
the upgrade from the testsystem this issue was not seen itself.
now let’s see, how it works with the production system.

AFAIK, those settings are now stored on the browser itself, not on the openhab server. So if your browser is set to clear cookies / data every time it quits (e.g. incognito mode), then you’d experience what you’ve described.

Thank you for reply.

To store the settings in the browser cache/cookies is the most worst idea ever :unamused:

There are many devices accessing the UI, and now I have to set every single devices with the settings to display the items correctly.

Please change it again, e.g. if there are no settings on the device (cache/cookies), then the sever settings will considered.

Kind regards

Hi everyone, are persistence blocks working for you? I save my rules and even recreate the blocks after the update, but still having this error:

TypeError: undefined has no such function "minimumSince"

I completed the upgrade from 4.1 to 4.2 without any major problem. I only have the dbquery bridge in state “unknown”. I tried to restart and trace the binding but I don’t have any error.
Anyone has the same problem?

1 Like

Hi,

I’ve updated to 4.2 through the docker image “Tag:latest” on my Synology. While most of the update went smooth, I have a problem with one HTTP Thing which stays in state “unknown”. Enabling DEBUG on the HTTP Binding showed me the HTTP GET request is incomplete, the Header with the Bearer token is missing. The server response is “failed: 422 Unprocessable Content”. Here the log output:

2024-07-10 12:46:45.749 [INFO ] [nding.http.internal.HttpThingHandler] - Using the secure client for thing 'http:url:85407df993'.
2024-07-10 12:46:45.749 [DEBUG] [nding.http.internal.HttpThingHandler] - No authentication configured for thing 'http:url:85407df993'
2024-07-10 12:46:46.871 [DEBUG] [p.internal.http.HttpResponseListener] - Requesting 'https://api.url.de/data/intraday/DE_LU/15?tz=UTC%252B01:00&from=2024-07-10T12:46:00%252B01:00&unit=EUR-ct_kWh' (method='GET', content='null') failed: 422 Unprocessable Content

This is the Code of the Thing:

UID: http:url:85407df993
label: HTTP URL Thing
thingTypeUID: http:url
configuration:
  authMode: BASIC
  headers:
    - Authorization= Bearer
      <token here>
  ignoreSSLErrors: false
  baseURL: https://api.url.de/data/
  delay: 0
  stateMethod: GET
  refresh: 900
  commandMethod: GET
  timeout: 3000
  bufferSize: 4096

How can I fix this? I verified the command line using curl w/ the Bearer token works as expected.

Thanks

Why don’t you use TOKEN as auth method? See HTTP - Bindings | openHAB

… well, I tried that - no difference. Also I put the Bearer token into the password field. Its still not sent with the request while the server still returns 422.

2024-07-10 16:45:43.316 [INFO ] [nding.http.internal.HttpThingHandler] - Using the secure client for thing 'http:url:85407df993'.
2024-07-10 16:45:43.316 [DEBUG] [nding.http.internal.HttpThingHandler] - Token/Bearer Authentication configured for thing 'http:url:85407df993'
2024-07-10 16:45:44.440 [DEBUG] [p.internal.http.HttpResponseListener] - Requesting 'https://api.url.de/data/intraday/DE_LU/15?tz=UTC%252B01:00&from=2024-07-10T16:45:00%252B01:00&unit=EUR-ct_kWh' (method='GET', content='null') failed: 422 Unprocessable Content

Do you have an example how to do it?

Thanks!

Can you please show the complete thing with channels?

Hi,

I have exactly the same issue. None of my addons are being loaded and manual install via console or ui does not work. Here the line from the log:

11:31:03.787 [ERROR] [.core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-tr064, openhab-binding-dwdunwetter, openhab-binding-exec, openhab-binding-chatgpt, openhab-binding-coronastats, openhab-misc-openhabcloud, openhab-binding-network, openhab-binding-amazonechocontrol, openhab-ui-habpanel, openhab-binding-mqtt, openhab-binding-netatmo, openhab-transformation-map, openhab-binding-ipcamera, openhab-transformation-exec, openhab-core-config-discovery-addon-usb, openhab-binding-systeminfo, openhab-binding-magentatv, openhab-binding-serial, openhab-persistence-jdbc-mariadb, openhab-binding-neato, openhab-transformation-xpath, openhab-persistence-rrd4j, openhab-binding-ntp, openhab-binding-http, openhab-binding-astro, openhab-voice-pollytts, openhab-binding-avmfritz, openhab-binding-smartthings, openhab-ui-habot, openhab-automation-jsscripting, openhab-binding-chromecast, openhab-binding-nuki, openhab-binding-dwdpollenflug, openhab-transformation-jinja, openhab-binding-upnpcontrol, openhab-core-config-discovery-addon-ip, openhab-binding-fronius, openhab-core-config-discovery-addon-mdns, openhab-core-config-discovery-addon-upnp, openhab-binding-mail, openhab-binding-tado, openhab-core-config-discovery-addon-sddp, openhab-binding-wled, openhab-binding-sonos, openhab-transformation-regex, openhab-binding-openuv, openhab-transformation-jsonpath, openhab-automation-jythonscripting, openhab-ui-basic, openhab-binding-gardena, openhab-binding-snmp': Error: Error downloading mvn:org.apache.httpcomponents/httpclient-osgi/4.5.13 Error downloading mvn:org.apache.httpcomponents/httpcore-osgi/4.4.13

I am running the latest official debian docker build on a synology nas. For now I have reverted to a config snapshot from a few days ago and am using the 4.1 version.

And yes, network connection from the container works fine when I test it from a bash inside the container.

I’ve noticed that the /overview page of my Openhab returns the status code 404. You don’t see it in the browser directly, but in the network tab in Developer tools.

Then I’ve checked the demo and it seems the Openhab demo suffers from the same issue: https://demo.openhab.org/overview

Tested in icognito mode in 2 different browser.

Should I open a Github issue for this? Just weird that no one else has noticed this so far.

Yes. Not so weird if you have to open a developer tool to see it though. If it’s not something that a developer is explicitely looking for or involves working on the overview page itself it could easily have been missed. Most end users don’t look at the developer tools in their browser.

Duh! Never mind. I forgot to set the JavaScript Library Injection to chache after some tests.