openHAB and TP-Link KP303

Hi there

I have just purchased a TP-Link KP 303 - 3 Outlet Wifi powerstrip.

I have tried to get openHAB to discover this and it failed. I also checked the documentation for the TP-Link binding and currently there is no support for this device.

Is there a process that I need to get the above powerstrip added to TP-Link binding ?


Not that strange it didn’t discover that device, it’s brand new :smile:

You can try to add it manually as a hs300 or if that doesn’t work as a hs107. If either work I can add it. If it doesn’t work there need to be done some more research.

I manually added a KP200 as it looked close to the KP303.
It discovered 2 or the 3 outlets which is fine for now.

The Group power switch turns the two discovered outlets on and then returns to the OFF position and then does not work when selected until the power outlets are manually turned off.

I’ll dabble with trying to add a new thing for the 3rd power outlet but not sure that I’ll come up with anything.

This configuration will work fine for now. It would be nice in the future if the TP-Link binding was updated to include support for the KP303.


Thanks for the detailed feedback. I’ve created an issue on GitHub with some technical information: I’ll let you know when I’ve an updated version available.

It’s not possible to get the 3rd power outlet with another thing because the binding doesn’t support this. The HS300 has 6 outlets, so that might have been a possibility. But it expects data for all 6 sockets when updating, and I think the HS300 thing will give an error when used for the HL303 when it updates the state.

Did anyone manage to get the KP303 working in Openhab? Using KP303 in the thing definition doesn’t work. Using KP200, as previously mentioned works but only allows the first 2 plugs to be created as items. I tried HS300 but that didn’t work. Any insight?

FYI, I am running the eclipse market version of the TP-Link binding on OH 2.5.11.

Thank you,

The binding included with the 2.5.11 is newer than the marketplace, as the marketplace is still compatible with 2.4. Best try the included binding.

Thanks for the tip. The 2.5.11 binding did fix the KP303 but broke the dimmer switch. With the stock binding, when the brightness slider of a HS220 is adjusted, the light turns on. With the Marketplace binding, the light only turns on when the switch item is turned on.

That’s a change in behaviour that was introduced a few versions ago. It also took me by surprise, but it’s more in line with how other dimmer switches work (and I think may work better for voice assistants).

Hmm. That’s interesting. I have rules to dim my bathroom lights after 10pm and bring them back to full brightness at 6am. This is so that if someone gets up in the middle of the night and turns on the bathroom light, it doesn’t blind them. Problem is, that without a switch option, when the rule runs, it turns the light on. Guess I will have to decide what is more important, the dimmer or the KP303. lol.

Thanks for all the input,

I do something similar. All you need is a second line in your rule to turn it off using the state item.


The commands happen quickly enough that the dimmer will record the new brightness and then immediately turn off.

KP303 binding works well for me and has no impact on my other TPLINK devices.