openHab Android app 2.21 & 2.22 won't connect except on wifi

openHab 3.3.0
Android 5.02

I upgraded the app on my (admittedly ancient by today’s standards) phone from 2.18 to 2.22 and I could no longer connect unless I was on a wifi network. I always got the message “network not available”. I tried going back to 2.21 and got the same outcome. Returning to 2.18 cured the problem. I have a tablet with a slightly newer Android version but I haven’t tried upgrading the app yet. I could do so if it would help diagnose the problem.

Did you enter a wifi in the server settings? Settings => Server … => Advanced => Wi-Fi name

No, but then I don’t have it filled in in 2.18 either. Is it required in later versions (I stress: when it works is when I’m on wifi; when it doesn’t is when I don’t have wifi)?

I’ve also started to experience this same issue, and can confirm its the remote URL connection method as I am on Wifi at work and can not bring up the OH 3 UI interface; I don’t have any of the other GUI methods setup to test against.
If I setup a Quick Tile (Android 11) to an item, this also seems to work remotely.

Also peculiar I leverage OwnTracks and know things still pass through as I can see location updates and the trigger to open the garage for my spouse continues to work.

I have tested this with Stable and the Beta release from the F-droid repo.

1 Like

Update in my scenario, I grabbed a copy of the 2.20 from github and things returned to working for me.

However this install also linked to the Google Play store app and it auto updated itself back to 2.22 and the problem returned. I reverted back with Titanium and also managed to break the link to the Play Store to avoid another auto update (And yes I am aware of a check box to prevent auto updating in the Play Store, the app retains a icon badge that annoys me as I know there is an update out there).

If I can get time with my spouse’s phone, its a pixel 5 running Android 13, to set it up for remote access and see if I can replicate the issue.

1 Like

Just tested again with the following:
Pixel 5 stock Android 13
Fdroid install of OH 2.22.0

Turned off Wifi, forced closed the the app and the results; works as expected and loads OH UI 3 and I was even able to test some various light switches. Forced closed the app and tested again and it still continued to work.

I don’t have a good way to verify if it works on Android 12, but seems like things work fine if you stay on 2.20 or lower :thinking: :person_shrugging: