openHab Android client

Originally I had my openhab client set up with the local url pointing to my servers ip, and the external url pointing to

I’ve enabled authentication on my server now, and exposed it externally but I now can’t get the android client to work when I’m outside the house.

I have the local url pointing to my external dns and the username/password matches the one I set in the user.cfg. I have the remote url pointing also to the same external dns but it just won’t connect (the white spinner in the nav bar just keeps spinning for ever).

I can access my server from outside my house via a browser just fine, and project rotini also works fine externally.

Have you tried to bring it up using those addresses and user/passwords through the browser? That might give you more information about why it is failing.

Worked fine from the browser on the phone, same issue on the app though :frowning:

You might try calling the /rest/sitemaps api from a browser. I was having similar problems and it turned out the host uri being passed back to the app was the internal name. In my case I was using an nginx reverse proxy and I needed to add “proxy_set_header Host myhostname;myhostport” to the location mapping. The results from /rest/sitemaps was very helpful.

Yeah, thats the issue. Going to see if I can get iis to play ball :slight_smile: