OpenHab App doesnt work


I seached a lot for this issue, but I didnt find a solution for me.
OpenHab work fine, I get access from the browser on the PC or my Samsung S10 mobile phone. With the Samsung S10 mobile phone I get access remote and local by the OpenHab App as well.
When I try the access with my Sony mobile phone then I dont get access by the OpenHab App with the same setting. In the Settings the Remote settings are green.
When I start the Main UI first there is a white Screen and then a black screen.
This are my conditions:

  • Sony Xperia XQ-DE72 with Android 14
  • Openhab 3.4.5 (Openhabian) on RaspPi
  • OpenHab App 3.11.0

Have somebody a idea?
Thank you.

Best regards

Hello Martin,

I have a questions before I might be able to help:

Have you ever left your house (I mean far enough so that you did not have a wifi connection to your house) with your Samsung phone and got a remote connection?

With kindest regards

I also had some same problem.
Please delete your app cache in the android app settings and restart your phone.
After it should work.

Hello Joerg,

thanks for your message.

Yes, with the samsung phone I was far away of the wlan, additional I disable the wlan. In both cases the remote connection worked.

Best regards,

Hello Martin,

if the remote connection worked with your Samsung phone, I do not have an instant solution. The only hint I can give you, you can have a look at the log that is written by the app. You can access it by looking at the settings in the app (“Einstellungen” in German), and there at the bottom, you will find something like “Show protocol” or “Show log” (I do not know exactly because I have the German version, and there it says “Protokoll anzeigen”). Have a look at that log after you tried to connect remotely. Perhaps you can find the reason in that log.

And if you cannot find the reason, perhaps you can post that log here and we could try to help.

With kindest regards