openHAB App on Samsung Tab2 GT-P3110

I’ve just installed openHAB app on my Samsung Tab 2 running Android 4.2.2 Kernel version 3.0.31-1249439 from this website
openHAB . I actually had to download it onto my linux laptop and then transfer the file as it wouldn’t download from the site directly into the Tab.
This was successful and the App starts on the Tab. It also found the correct server address automatically so I know it’s connected to openHAB on my RPi 3.
When it tries to connect however I get an error response as shown in the attached jpeg
My laptop connects to the Basic UI with no issues. My Samsung phone also connects ok via the openHAB app. I want to use the Tab mounted on the wall as a central control point for the house so could really do with this working
Thanks for any advice
Tim Scott

Look in openhab.log for the full error. If you couldn’t download the app from the play store, it seems likely to me that you are running a version of Android on that Tab that is not supported by the app. That could be the problem as well. The page says it requires Android 4.4 or later.

I’ll have a look at the log. Is that the log I can see in logviewer ?
The download page does very specifically say it’s for Android 4.2.2 or is that incorrect ?

Thanks for the advice


I don’t know anything about this third party website. The Play Store lists 4.4 or later as the minimum Android required.

When I try to connect there are no entries showing an error in the logviewer. Nothing happens in the log at all.

… and the maintainers are going to even raise the minimum api level, see:

If you’re lucky, you’ll find a custom rom for your old tablet.
My stoneage Galaxy Tab (1) runs on Android 7 for this purpose :wink:

It should work to connect through the browser instead of the app.

Well, when using it as wall tablet you’re likely want to use a kiosk browser then.

If you take e.g. the “habpanelviewer” as kiosk browser for the webui/basicui, then you’ll be facing the same issue: Minimum Android 4.4 for basic functionality and 6.0 for all features :wink:

Therefore I decided to upgrade the Samsung tablet to a slightly more recent Android…
Now I can choose between HPV or openHAB app. Both run fine on the old piece.

But I have an PoE Android desk phone here (GXV3275) which is still on Android 4.2.2 and will never get an update anymore. Unfortunately, this device is quite rare and no custom rom available.

If you can recommend a stable kiosk browser for 4.2.2, I’d be happy to give it a try…

So the name of that webpage needs to be changed. It gives the impression that it is a version specifically designed to be used with 4.2.2 . It’s a shame that they demand ever improving hardware to run the app on. One of the joys of Open Source is that lots of older hardware can still have a purpose and not just be retired to the junk heap. I run Linux on all my computers and haven’t had to upgrade the hardware for over 10 years. Run Windows 10 and they come to a standstill, but the useability is still more than adequate on Linux and in many cases better than a new Windows 10 machine.

While I feel the same more or less (would love to continue using my old gadgets too), I can really understand that the maintainers have to make painful decisions from time to time for technical or security reasons though. That’s life :wink:

And: We should be grateful for their ongoing development effort. Agree?

btw: The old software isn’t gone:

Old apk version will be always available via GitHub releases:

Need to add, that the manufacturer of your tablet has abandoned the support for the device you’ve paid for. Your hardware is good enough for the app (my even older Galaxy Tab 1 does run it well!)

You might consider to blame the manufacturer of your device instead of the developers of our app :wink:

1 Like

You should update Android on your tablet.


Please do not download apk files from random webservers. You can get the latest version from the play store and older versions from

Sometime important libraries raise their minimum supported version and all we could do is to

  1. maintain our own version (too much work)
  2. Update the minimum supported version of the app.

With a custom rom, you can still get newer android versions on old hardware.

I only buy hardware that is supported by LineageOS, so I get updates much longer.

The app version is no longer supported, but you can try to connect to the server via http instead of https. It seems that your tablet isn’t supporting the ssl versions the server offers (for a good reason! They’re old and insecure).

After nearly 4 hours of fiddling yesterday I managed to update my Tablet to Android 6. The issues were that a fair few of the instructions were wrong on the update website. The worse was to tell me to press the up volume and power on buttons to get to the Download mode of the tablet. This actually took me to a totally different mode. The correct key press was Down volume and power on. After that it all went pretty well
Thanks for the encouragement to do this. I was a bit nervous to be honest but it worked out OK