openHAB binding for meater probes

For me it stopped working - I don’t know when. I have just configured a project in Postman from GitHub - apption-labs/meater-cloud-public-rest-api: MEATER Cloud REST API documentation., but I get this response even when my Block is on with all four probes, and the app also working correctly:

    "status": "OK",
    "statusCode": 200,
    "data": {
        "devices": []
    "meta": {}

If anyone can confirm this, I’ll create an issue in the repo. There was an app update recently, so I’m wondering if they changed the API, and forgot about their public API or abandoned it?

I’ve not previously used postman to query the meater API before, but after logging in and using the provided token I get the same response, regardless of block on/off cloud status. App works fine from mobile-only connection.
Trying to login with wrong credentials/token gives expected 401 on /login as well as /devices, so API seems connected.

I have created:

@jannegpriv, @digitaldan - does it work for you? Still curious if the issue is general or somehow targeted. :wink:

Hmm, i’ll give it a try when i get home from work today. I last used my probes maybe 2-3 weeks ago and was working then (i have them announce starting / ready / resting to my kitchen alexa)

1 Like

Mine appears to not work anymore as well, all 4 probes remain offline, but show up in the meater app.

1 Like

Ok, so my meater probes are showing online when i power my block up, which is showing that firmware is installed. The mobile app has been bugging me for months to upgrade my firmware, but of course thats always when i’m about to use it , so i have not actually upgraded. I wonder if its an issue with 3.x?

1 Like

I do not own the block, only a single probe.
It worked when I tested some weeks ago, but I will test later today.

1 Like

I’ve tried several scenarios and it seems to me that (on block with the probes are only exposed to the public API once a cook is started.
So when starting a cook on 2 probes, only those 2 show up in the get devices( and switch online after the API gets refreshed by openHAB.
I see the same behaviour on a parallel running HA-instance.

Stopping the cook also brings the probes offline after some time(funny thing is that the elapsed cook time keeps counting upwards after stopping the cook), when the block disconnects(automatic behaviour when no active cooks).

Now I’m not sure if this is consistent with previous behaviour and if this has changed over firmware versions(only started using the meater block last November).

1 Like

Thanks, I now see the same behavior. When starting a cook, the probe appears. I’m pretty sure this behavior changed, otherwise I wouldn’t have been able to discover all my probes (without starting four cooks which I’m sure I didn’t). I have updated the issue I created with this information. Thanks all!

Definitely different then mine, my probes show up when i power on my block. Sounds like a firmware difference.

I’m on and I’m seeing the same behavior as @j.hoekstra and @laursen.

for me the same