Openhab-binding-tcp1 produces error on start-up

Everytime I start up (or reboot) OpenHab2, I get the following error:

2017-02-22 12:16:30.812 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-binding-tcp1': Feature named 'openhab-binding-tcp1/0.0.0' is not installed

I have the following binding “binding-tcp1 - 1.9.0”.
I think this binding came out of-the-box with my OpenHab2, since I don’t recall installing it myself.

According to PaperUI it is already installed. Uninstalling via PaperUI does not work.

How do I troubleshoot this error?


Take a look at your addons.cfg if it is installed through text file:

binding = tcp1

If not go to your /userdata/etc/org.openhab.addons.cfg and take a look.
In both cases uncomment the line or delete the tcp1 part if you need it uninstalled.

Last chance: take a look into your /addons folder if you have the .jar placed in there.

Thanks for your help!

In addons.cfg nothing is referring to tcp/tcp1. In fact, every line is still commented (starts with #)

In /userdata/etc/org.openhab.addons.cfg also nothing refers to tcp:

package = standard
ui = basic,paper,habpanel,habmin
remote = true
binding = chromecast,denon1,irtrans1,knx1,ntp,plex1,sonos,network
voice = voicerss
misc = openhabcloud

The addon-folder only contains one .JAR file, not related to TCP (connectsdk).

Anything else I can check?

My last idea: log into your karaf console, do a bundle:list, note the number most left to the line with the tcp binding (if any) then do a
bundle:uninstall xxx where xxx is the number for the tcp binding.

Hi sihui,

Thank you.
I’ve logged on to the karaf console, and I’ve found the tcp binding (ID 188).
I uninstalled it (bundle:uninstall 188).
It doesn’t show up anymore. So whatever I’ve done, seems to be successfull.

However, when I reboot OpenHAB, I still get:

2017-02-22 15:02:30.165 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-binding-tcp1': Feature named 'openhab-binding-tcp1/0.0.0' is not installed

Also via PaperUI it is still installed. Uninstalling via PaperUI does not work.

Any other ideas?

How do I install this bundle via Karaf?


bundle:install org.openhab.binding.tcp (I guess)

I tried


(apparently, you need to specify the URL to the JAR file).

I couldn’t find the JAR file of, so I installed 1.9.0.b2. But it didn’t fix anything.