Openhab boot not working

Hi, today I wanted to activate my openhab again to finish my project. As always, I then connected to my Openhab UI via the IP address. It all worked. Because I needed the terminal again, I tried to establish a connection with Putty, but only got the error message “access denied”. So I rebooted the raspi with HDMI and discovered that the raspi hangs during boot after completing the “Finished Update UTMP about System Runlevel Changes” step. I waited 2 hours and nothing happened. I have restarted the Raspi several times, I can get to the UI. It does not work with Putty/HDMI or no input from the keyboard is accepted. What can I do there?

What does

in one of your last sentences mean?
Does it mean you get the web UI of openhab and that works ?
If that is the case I would expect that ssh should work as well - apart of that in your case ssh service does not run on ethernet but on localhost interface. I think to remember that there was a version where the service was disabled on network interface.
In case putty/ssh is not available via network interface then you need to get a console by using monitor and keyboard. Does it work when you connect it after booting the system and then connecting the equipment ?
Did you use port 22 to connect using putty/ssh ?

When I connect power to the Raspberry, after a short time I can access the Web UI via the IP. However, Putty does not work then. If I subsequently connect an HDMI cable with a keyboard, there is no signal via HDMI either. If I connect the HDMI cable and a keyboard before connecting the power cable, I can see the boot process via HDMI and it stops after the above step. Input via keyboard is not possible, putty does not work. However, the Web UI works in both cases.

Is it possible to get a console by then pressing CTRL+ALT+F1 or CTRL+ALT+F2 or CTRL+ALT+F3 ?
The screen might be blanked. Does it change when you hit the ESC key ?

Do you try to connect to Pi via putty/ssh using a windows computer ? Could it be that the windows firewall or antivirus program blocks the outgoing putty connection ?
Could you try https://www.thewindowsclub.com/how-to-use-port-query-tool-portqry-exe-in-windows-10 to see if the ssh port 22 on the remote pi is open and accepting connections ?

I have now restarted the Raspberry Pi. This time it hangs at the “Finished Daily man-db regeneration” step. CTRL+ALT+F1 stays on this screen, F2 and F3 lead to tty2 and tty3 consoles. I am supposed to log in there, but my password for openhab is not accepted

openhab is no user to login on the shell console.
Did you try openhabian?

Many thanks, now I finally have a console again in which I can enter something. Only the other error remains

Ok - first step.
What is remaining ?
In case you cannot conenct to openhab via web interface then check content of /var/log/openhab/openhab.log.
In case you refer to the putty/ssh connection then:

  • what is the output of sudo netstat -tulpn | grep ssh