Openhab cannot search for network device

Hi guys. I want to use network bindings but it can not work. I have an Ubuntu 16.04 PC which have a TP-LINK wireless card. I use it to transform my PC to a wireless router( because I wang to establish a local subnet). The ip of my PC is
After that, I have a Mac, which is connected to the WiFi estabilished by my wireless card, and get ip, which is Now I use Ubuntu arping to ping my Mac ip, I found it worked and latency is low with no packages missing. Now I use openHAB to search for network devices autmatically and use Wireshark to monitor arp or ICMP, I can see that on Wireshark, they communicate well.

But it can not search for the device anyway. Can anyone give me advice how to debug for the next step?

Are ARP and ICMP Ping working as the user account running OpenHAB?

Hi Bruce, sorry I don’t know what do you mean by “working as the user account running OpenHAB”. When I run OpenHAB, it does not ask me to verify a user account.

You should have installed OpenHAB to run as a non-root user who has less privileges. Installing to run as root is not supported.

But using automatic installation, I think the default is using sudo. Also I don’t understand why the priority has issues?

Does that mean I need to use manual installation?

No. even if using OpenHABian, it asks you for the user name which will be running OH when first running the configuration. I am not aware of any of the official OpenHAB installations that install as the root user.

Actually you can say that all parts are installed directly under “/”, for example “/etc” or “/var”, if you use package installation. I think sudo is necessary.

For some configuration, yes. What user are you logged in as when using sudo ? That user need to be able to ping & arp successfully without using sudo.