Openhab cloud connection stops working, does not try to reconnect

Yep, not sure if this has been investigated here in the community in detail. One idea that has been raised is to have HTTP GET to and see if it times out. I am not sure if this is trivial to implement as you cannot (to my knowledge, at least) use uuid+secret to get through the HTTP Basic authentication.

I don’t have new information to share but can confirm that I also am affected by this. Wife acceptance factor is starting to be affected by this.

Same behavior as described:
Google home stops being able to reach openHAB.
Check my and my instance appears Offline.
Check my local instance and immediately after I press the “save” button in the openHAB cloud integration options, my instance switches to online in the cloud openHAB.
Google home is once again able to reach out to openHAB.
I don’t have exact dates or hours but I’ll be keeping an eye on this thread now.

I don’t know the code, but I was thinking more of having an application level ping/pong message exchange using the same connection. My understanding was that the existing ping/pong watchdog mechanism was at a lower level of the library.

I was thinking of a ping/pong exchange that actually required some verifiable data to be returned by the server, and if that data is not retrieved correctly, then the openhab connector assumes the connection is dropped and reconnects. This mechanism being more cpu/net expensive and possibly requiring more server resources could be run at a (much) lower frequency than the existing ping/pong.

This is just my thinking without knowing any of the code of either server/connector, so I will apologize in advance if what I just wrote is pure gibberish. :slight_smile:

I just noticed that I’m not able to reach, and created this post: not reachable?

Do you guys reckon this might be related??
If I use a vpn in germany I can reach to This is weird…

No, should not be related as the two are pointing to different servers at different hosters.

The troubleshooting versions (for openHAB 3.2.0 and for openHAB 3.3.0-SNAPSHOT) have been updated.

If this works for you without issues I am proceeding to merge it to main codebase. Good improvements for everyone.

Appreciate all the testing for this, please report if it runs without issues.

You can upgrade from previous troubleshooting version as follows:

  1. Remove the addon using MainUI
  2. Reinstall the addon
1 Like

Thanks for the update. I have uninstalled the old addon and reinstalled the new one today.

For some reason I was unable to uninstall the old troubleshooting connector. Every time I clicked uninstall on either the troubleshooting connector or the regular openhab cloud connector entry I got an error message in the UI, but nothing in the logs. Restarting openhab didn’t help, so I ended up doing the following:

  • Cleared the cache and reset permissions. After that nothing worked, UI was just all black every time I tried to restart openhab.
  • Downgraded to 3.2.0 (stable).
  • Upgraded to 3.3.0~S2902 (I was using 3.3.0~S2784 before)
  • Uninstalled the connector
  • Restarted openhab and verified no connector was installed
  • Installed the new 3.3.0 snapshot troubleshooting cloud connector (bundle

Everything seems to be working ok now, and I see the ping/pong messages and other trace logs from CloudClient and OkHttpClient.

Note that I am not present at this house very much in the summer months. I will check the install remotely periodically and every time I am at that location.


Quick update: Everything has worked flawlessly for me since early May. Will continue testing with my configuration unchanged until further notice.

1 Like

Funny you should say that. I appear to have had one of the phantom disconnect/connects early this morning, after going a long time without needing to restart it.

1 Like

All, those of who experience the problem. Next time you have the offline issue, can you verify whether cloud notifications work and reach your mobile devices and web?

Old discussions in GitHub do tell that they indeed might still work.

This would further narrow down the issue on cloud side.


Dear, I had downtime yesterday after 7 days. The cloud suddenly stopped working. The notifications kept working though.

I noticed when I restarted my Telenet router that the problem was solved. I think it’s a problem with the reconnection of the cloud.

Hi, I am also having this issue every few weeks or so. Notifications keep working. Mobile apps and Google Home are not working (they cannot reach my local openhab instance any more via the cloud).



I regularly have the problem that my raspberry pi 4 is no longer connected to the cloud. This week I have had it twice. It was offline from 7to 7h(12h) I think there is a reconnect somewhere every 12h?

I get status code 500ter back in my app. All notifications are still working though.

I noticed that the problem is solved after unplugging and directly deer plugging in the network cable.

Can anyone help me?

This upcoming fix on server side might help [WIP] updated disconnection logic and clean up unused noise by digitaldan · Pull Request #381 · openhab/openhab-cloud · GitHub

@digitaldan and I worked to identify “race conditions” which might result the cloud thinking that session is offline even though it is connected. The fixes from him should at least resolve some issues, potentially also a root cause for the issues documented here.


Great! Thanks! When commes this fix online?

Please read the latest comment from @digitaldan in the link @ssalonen posted.

Hello again. Has the upcoming fix been implemented yet on the server?

Today I had the same problem happen again. Same as the last time:

  • Ping/pongs 100.0000% ok. I checked over 24 hours back in the log, and there was nothing wrong.

  • openhab app could not connect. Error message: “Your openHAB server is offline while the cloud instance is running.”

  • website says: " Your openHAB is not online. Please check if your installation is running or recheck the openHAB settings in your account."

  • Sending a notification did in fact work. It arrived as a notification on my phone instantly and could be display in the openhab app, however nothing else in the app worked as described above. I have a button in my house that has an associated rule that executes this openhab script code:
    sendNotification(“”, “Test notification.”)

  • Per usual, clicking the “Save” button in the OpenHAB cloud menu fixed it all immediately.

1 Like

…and now it happened again, exactly the same way as 8 days ago.

Hey guys, same as above as recently as last night (12th Nov 2022) ping and pongs are fine. Cloud connector offline.disconnect and reconnects in logs, reboot of pi4 fixes the issue.

The problem was a lot more common over the last month and got a lot better with the Debug Binding (3.3) only failed once since its install (last night)

Potential Debug notes:
I did install the the cloud connector through text files (not GUI)

I live in South Africa (pongs are over 200ms) (Stable 1GB Fibre)

There are multiple disconnects and reconnects in log when issue occurs

App works fine (Local)

I dont have any notifications setup

It happened again Nov 18 and Nov 19, same thing as before.