Openhab cloud connection stops working, does not try to reconnect

Funny you should say that. I appear to have had one of the phantom disconnect/connects early this morning, after going a long time without needing to restart it.

1 Like

All, those of who experience the problem. Next time you have the offline issue, can you verify whether cloud notifications work and reach your mobile devices and web?

Old discussions in GitHub do tell that they indeed might still work.

This would further narrow down the issue on cloud side.


Dear, I had downtime yesterday after 7 days. The cloud suddenly stopped working. The notifications kept working though.

I noticed when I restarted my Telenet router that the problem was solved. I think it’s a problem with the reconnection of the cloud.

Hi, I am also having this issue every few weeks or so. Notifications keep working. Mobile apps and Google Home are not working (they cannot reach my local openhab instance any more via the cloud).



I regularly have the problem that my raspberry pi 4 is no longer connected to the cloud. This week I have had it twice. It was offline from 7to 7h(12h) I think there is a reconnect somewhere every 12h?

I get status code 500ter back in my app. All notifications are still working though.

I noticed that the problem is solved after unplugging and directly deer plugging in the network cable.

Can anyone help me?

This upcoming fix on server side might help [WIP] updated disconnection logic and clean up unused noise by digitaldan · Pull Request #381 · openhab/openhab-cloud · GitHub

@digitaldan and I worked to identify “race conditions” which might result the cloud thinking that session is offline even though it is connected. The fixes from him should at least resolve some issues, potentially also a root cause for the issues documented here.


Great! Thanks! When commes this fix online?

Please read the latest comment from @digitaldan in the link @ssalonen posted.

Hello again. Has the upcoming fix been implemented yet on the server?

Today I had the same problem happen again. Same as the last time:

  • Ping/pongs 100.0000% ok. I checked over 24 hours back in the log, and there was nothing wrong.

  • openhab app could not connect. Error message: “Your openHAB server is offline while the cloud instance is running.”

  • website says: " Your openHAB is not online. Please check if your installation is running or recheck the openHAB settings in your account."

  • Sending a notification did in fact work. It arrived as a notification on my phone instantly and could be display in the openhab app, however nothing else in the app worked as described above. I have a button in my house that has an associated rule that executes this openhab script code:
    sendNotification(“”, “Test notification.”)

  • Per usual, clicking the “Save” button in the OpenHAB cloud menu fixed it all immediately.

1 Like

…and now it happened again, exactly the same way as 8 days ago.

Hey guys, same as above as recently as last night (12th Nov 2022) ping and pongs are fine. Cloud connector offline.disconnect and reconnects in logs, reboot of pi4 fixes the issue.

The problem was a lot more common over the last month and got a lot better with the Debug Binding (3.3) only failed once since its install (last night)

Potential Debug notes:
I did install the the cloud connector through text files (not GUI)

I live in South Africa (pongs are over 200ms) (Stable 1GB Fibre)

There are multiple disconnects and reconnects in log when issue occurs

App works fine (Local)

I dont have any notifications setup

It happened again Nov 18 and Nov 19, same thing as before.


Hi All,

Following this thread for a while as I am experiencing this issue as well. I wanted to inform that I upgraded from OH3.3 to 3.4 last week and encountered the problem again today. A simple “save” on the UI openHAB cloud page got me back online. There were no messages in the openhab.log after the last successful connect to openhabcloud. I have log level set to TRACE now and will send info as soon as I have the issue again. If anything else is helpfull for troubleshooting, please let me know.


Hi @joseph @ssalonen

I have also been having this issue intermittantly, it’s been worse since October 2022. I was running 2.5.10 so upgraded to 3.4, but the issue remained. I changed the connection to the Pi from wifi to ethernet in case it was dropping, but that didn’t help.

Today it failed at 09:30 UK time (12-01-2023), apparently due to ping timeout. I’m not sure that it worked correctly after that, it was 14:30 that I noticed it failed as Alex said ‘the hub is not responding’. There is nothing else in the log apart from ping/pong even when I ask Alexa to turn on a light, I would have expected to see something.

Probably I’ll implement one of these scrpts that restarts the connector if it fails, clearly this is a hard bug to fix as has been around for a while.

Did yours also fail at 09:30 today? I would guess it did for everyone, unless it is my internet provider.

Maybe someone could increase the ping timeout threshold to make it less sensitive?

2023-01-12 09:28:12.765 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:28:12.789 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO pong: 24 ms
2023-01-12 09:28:37.790 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:28:37.816 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO pong: 26 ms
2023-01-12 09:29:02.819 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:29:03.342 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO pong: 522 ms
2023-01-12 09:29:28.344 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:29:29.872 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO pong: 1529 ms
2023-01-12 09:29:54.874 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:29:56.085 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO pong: 1212 ms
2023-01-12 09:30:21.091 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:30:26.095 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO CLOSE: ping timeout
2023-01-12 09:30:26.097 [WARN ] [io.openhabcloud.internal.CloudClient] - Socket.IO disconnected: ping timeout
2023-01-12 09:30:26.098 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = 36…5d, base URL = http://localhost:8080)
2023-01-12 09:30:27.161 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO re-connecting (attempt 1)
2023-01-12 09:30:27.164 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2023-01-12 09:30:27.166 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2023-01-12 09:30:37.337 [DEBUG] [io.openhabcloud.internal.CloudClient] - Error connecting to the openHAB Cloud instance: EngineIOException xhr poll error. Should reconnect automatically.
2023-01-12 09:30:37.341 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO re-connect attempt error: SocketIOException Connection error
2023-01-12 09:30:38.517 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO re-connecting (attempt 2)
2023-01-12 09:32:07.660 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO re-connecting (attempt 8)
2023-01-12 09:32:07.662 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2023-01-12 09:32:07.664 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2023-01-12 09:32:07.841 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO OPEN
2023-01-12 09:32:07.845 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO re-connected successfully (attempt 8)
2023-01-12 09:32:07.847 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2023-01-12 09:32:07.848 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2023-01-12 09:32:07.852 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2023-01-12 09:32:07.931 [TRACE] [io.openhabcloud.internal.CloudClient] - Socket.IO Packet: CONNECT (0)
2023-01-12 09:32:07.934 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO connected
2023-01-12 09:32:07.937 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = 36…5d, base URL = http://localhost:8080)
2023-01-12 09:32:07.939 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2023-01-12 09:32:32.853 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:32:32.875 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO pong: 22 ms
2023-01-12 09:32:57.877 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO ping
2023-01-12 09:32:57.899 [DEBUG] [io.openhabcloud.internal.CloudClient] - Socket.IO pong: 22 ms
Then nothing but ping/pongs.

Hi Miles,

For me it did not fail yet after I have set the log level to TRACE.’
The only messages I see are the “ping pong” messages.


I have been on vacation. It seems, that my cloud connection also crashed on 11.01 or 12.01

Uh. This ist getting worse.
Two crashes within the last 4 days

Hey everyone,
I’m also having the same issue. Just like momo90 my connection stopped twice in a very short period. I have two instances running on different locations and both stopped communicating with the Cloud at the same time.

Read here for a rule to restart your cloud connector and some discussion about the ongoing problem. It’s a stopgap solution until the root cause can be determined.

1 Like

FYI, there’s maintenance tomorrow (January 29), so it is expected that there will be disconnections.