[openHAB Cloud] Google "Couldn't update the setting. Check your connection."

Hi folks I know there is similar issues on the forums, but I don’t want to restart an old thread just adding to somone elses woes, so I’ll stick mine in here and see if anyone has anything obvious to add.

My items file contains a combination of:

Switch  GF_LivingRoom_Light1_Toggle1xy     "On/Off"        (Home, GF, GF_LivingRoom) [ "Lighting" ] { channel="hue:0220:1:6:brightness" }

Rollershutter GarageDoorDummy1 "GD2" <garagedoor> [ "Switchable" ]

The light is real the Garage Door clearly isn’t, I’ve tried them both alone and together, but when I connect via Google Home I get the usual

Couldn't update the setting. Check your connection.

Just to clarify, I’ve literally only added things to my items file, i’m not supposed to update anything else right?

I’ve connected my installation to myOpenHab and it reports as being online.

What important piece of information am I missing?



Have you tried this: tag validator


Thanks @aart

My current items file incarnation reports this:

So I assume its okay…

For your light device its oke, but your roller shutter doesn’t show up.
Roller shutter is not supported by the tag validator, but when you use a [ “Switchable” ] tag the item must show up in the validator.
So the tag is not recognized, check your item again:

itemtype itemname "labeltext [stateformat]" <iconname> (group1, group2, ...) ["tag1", "tag2", ...] {bindingconfig}

Yeah that was just a dummy so that was okay. The light is real so I removed the rollershutter as its a noop.

Love to get this as part of base package… or maybe just a simple tool you could run on your pi. This way it could check local install first then my openHAB.

Checking local good as sometime my openHAB connection could be a problem. That’s all

There is a place in Habmin for tools, like the zwave one. Sounds like a candidate for integration?

Alright, back to this mornings issues.

I’ve basically cleared out the whole of the items/sitemap/things directories and put:

Switch  GF_Kitchen_Light1_Toggle     "On/Off"       (Home, GF_Kitchen, gKitchen) { channel="hue:0220:1:2:brightness" }
Switch KitchenLights "Kitchen Lights" <light> (gKitchen) [ "Lighting" ]

That is all that is in there, yet I still see the same issues. The lovely tool @aart has created checks out fine… what am I missing?

quick note: My Google Home mobile App also spits out “Couldn’t update the setting. Check your connection.” sometimes after I authorize GH on myopenhab.org.

Even with this message, the devices will still show up in the GH App. I have done the setup more than 10 times because I was writing a tutorial and I was testing it extensively.

Check the FAQ here: HowTo: Listen & Talk to your Home

In general: If your cloud connector is set to remote+notify, you Items have been exposed, have received 1 update and as a result: can be displayed on https://myopenhab.org/items and have proper labels and tags… they will show up in GH App.

Yeah so I have my item listed in the Items page:

Uploading: Screenshot 2018-11-28 at 21.10.17.png…

Which updated 5 minutes ago, then I reprocessed the auth on 2 different phones with 2 different google users and also 2 different openhab logins to the same openhab install. None of that combo worked. Its such a blackbox though I don’t know where to look other than in the log tails and the items file which offers up no clue.

can you post a screenshot of PaperUI -> Configuration -> Services -> IO -> openHAB Cloud -> Configure?

Ps: screenshot on previous post didn’t work

Yeah sorry old screenshot here:

I’ve implemented the switch from your walkthrough also, same output… 2 secs other screenshot coming…

looks good

post the contents of the following file plz:

expose=( \
  "Voice_Robot", \

also correct…

grrrr :slight_smile: I can’t find something wrong.

Did you double check in the Google Home mobile App if the Item appears as a device (even after you get this error)?

Yeah the only things listed are my chromecasts. Sad times!

oooh hold on, one phone seems to have found something… weird, I shall dig about and see if it actually works, 2 mins

remove in Google Home App the link to myopenhab
clear all previous app auths on https://myopenhab.org/applications and try again.

It will work (eventually :stuck_out_tongue:)