Openhab cloud, push notifications not working

I stopped getting notifications (banners) Sunday (March 31).

I have the same issue from about 2 weeks ago. Screen notifications in iOS just stopped. But they are all in the notifications section of app and browser.
Same on wife’s phone too. I haven’t changed iOS version so can only think the app has some issue?

Yesterday afternoon it was working again but today the same problem again. Notifikation are visible in the App but no sound or push. Maybe the Problem is Apple. I am on 17.4.

Since the afternoon of April 5 the push notifications are once working again for me. It has been 2 days now and all seems good. Hoping the problem is solved.

On my side, I still do not get notifications anymore on iPhone & iPad. Not sure when it started though! But I’d say this is broken in my case for a couple of days… Sunday April 7th, 9PM CET : Still KO.

Hi, so its strange as i don’t see any errors from Apple when sending push messages in our openhab cloud logs, its just seems to silently fail, which is making this very hard to debug. The previous time this happened, it seemed to correct itself after a few days, which is also very odd. In any case, I went ahead and restarted all the backend processes, lets see if that helps.


Hey Dan! Thanks a lot for looking into this !
I do confirm that the background processes restart you performed helped in my case. It seems I’m back up and running again getting notifications on iPad and iPhone !!!

Thanks a lot !!!

1 Like

At the Moment it is working again. Hopefully it will not stop again tomorrow.

During the Last days i was still able to initiate a test notification via the myopenhab cloud website. This Notification was delivered with Sound and push. But notifications from OpenHAB were online visible in the App. Therefore i thought that probably the Problem is on the Apple Server.

It’s working again here. Received a notification this morning. :+1:

up to now it is working perfect. :slight_smile:

@digitaldan Thank you very much for your help! :slight_smile:

Same here. Working since the services restart.

It worked for a few days but stopped again yesterday for me.

It worked for 12 days, unfortunately the notification no longer works again.
My wife and I have an iphone.

Same for me :frowning:
No push on ios

Hi guys,
I’ve tested this again this morning and it seems to be working okay on my side.
I don’t know if it could be region specific or not…
@digitaldan, any idea ?

Its not clear what the problem is , especially since we have not changed anything in the service in a while. I suspect this issue is local to a particular server instance maybe leaking an object or being denied push access, but its seems to effect only a small number of users on that particular instance. It would be helpful for people to confirm that they can push a notification from the cloud web interface ( its under username → devices → send message ) when its not working from their OH system.

I can confirm that a test message from the cloud web interface is working (tested just now) - but notifications from my local openhab is still not working.

Test messages from the cloud Website work perfect, but real Push messages from OpenHAB are visible in the OpenHAB-App notification section but not on the iPhone itself ( no Sound and no Notification)

iPhone 13 iOS 17.4

Its working again

Not for me - still not working :frowning: