OpenHAB Cloud shows a dashboard from a long time ago

I’ve been getting an error in the logs recently:

Error connecting to the openHAB Cloud instance: already connected.

When I go to I see a dahboard from a long time ago. There is no other instances of OH running and there are no files on my Pi that have the same code as what is being displayed on the cloud.

The one on the cloud is 3.3.0, I am on 4.0.0M5 now.

Any ideas?

The cloud server and add-on act as a reverse proxy. There is nothing on the cloud that can show an old dashboard. The dashboard lives on your computers and the cloud just provides a secure channel to your OH instance. Everything you see at comes from your machines, not the cloud server.

If you see anything besides “your openHAB instance is down” (or the like), somewhere you have this old 3.3.0 instance running and connected to the cloud server. That’s the only way you could be seeing anything like this.

I have very carefully and slowly looked through all running docker containers that I have running, 3 times, and I definitely do not have another instance. I don’t have many to look through; Plex, Grafana, Portainer etc.
The dashboard showing on the cloud is probably more than 9 months old?

And I can’t log in with my password

It’s gotta be coming from somewhere. If not your machines than your account is compromised and someone else’s OH instance is showing up there.

You can stop openHAB, delete the secret and uuid. Restart OH to generate new ones and then in replace the old values with the new values. That will remove the existing instance from your account and allow the new instance to connect.

I got my new UUID and secret. I’m still getting the same error in the log, but now I get nothing from the cloud

Does show your instance as online? Did it mention in the logs that it connected?

The first message about it in the logs says

Error connecting to the openHAB Cloud instance: not authorized.

then all the rest are

Error connecting to the openHAB Cloud instance: already connected.

I’m not sure where to go from here. The “not authorized” usually means the uuid and secret doesn’t match between the instance and the cloud server.

I’ve never seen the “already connected” message.

I just tried changing my uuid and secret randomly in the cloud UI to something completely wrong and uninstalled the binding. It says I’m still online, but obviously not.