OpenHab Cloud Will Not Connect

I’ve got the same kind of issue with as Aaron has. I’m running OH2 and after installing the openhab cloud connector states “offline” and at the bottom it says I’m running OH 1.x

So I came across this thread and after checking my Java version it says the following:
java version "1.8.0_65"
Java ™ SE Runtime Enviroment (build 1.8.0_65-b17)
Java Hotspot™ Client VM (build 25.65-b01, mixed mode)

Now I suspect this is not a high enough version right? The “65” should be “101” instead?

I’m running Raspbian Jessie on an RPi3.
When I do
sudo apt-get update
sudo apt-get install oracle-java8-jdk
I get a message saying that I already have the lastest version.

How to I go about getting up to a higher version?


Yeah unfortunately the default repositories on rasbian have too old java.

I use the following in my raspbian ansible setup:

echo "deb wily main" | tee /etc/apt/sources.list.d/webupd8team-java.list
echo "deb-src wily main" | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp:// --recv-keys EEA14886
apt-get update
echo debconf shared/accepted-oracle-license-v1-1 select true |  sudo debconf-set-selections 
echo debconf shared/accepted-oracle-license-v1-1 seen true | sudo debconf-set-selections
apt-get install -y oracle-java8-installer

The commands automatically accept the Oracle license which makes it suitable for unattended installation. The package comes from third party Ubuntu PPA that should be compatible raspbian Jessie.

You should probably remove the existing java8 before installing the new one.


Oh thank you so much! I Will give this a try today, so looking forward to follow my home solution when away from the house. :slight_smile:


I got everything installed by following your commands listed above. And the is now online and working! hurray! :slight_smile:

I removed the old java first as you suggested as well. So now java -version i showing me that I got java 8 with 111 :slight_smile:

Thanks again!


Glad that Erik’s problem is resolved.

Any further ideas as to why I might still be having a problem?


The only difference you have is NGINX.
I guess now you have to find someone who is familiar with that …:innocent:

Or I could remove it and test? How do I safely remove it?

If you’ve installed it through openHABian, there may be also an uninstall option (don’t know, have never used openHABian)., otherwise try

Thank you. This has removed it successfully.

Still no connection, even with firewall off and port forwarding on etc.

Got it connected! :slight_smile:


How did you finally get it going? It’s always nice to hear HOW it worked out, not only THAT it works now…

After getting rid of nginx it still showed offline.

I visited myopenhab, deleted my account, created my account again. Still
showed offline.

I rebooted, logged out of my account, logged back in and it said online.

Its been online for a few hours now, and I briefly saw my full dashboard.

I’ve just been back online and find that after clicking the link to view
the dashboard it times out. 504 Gateway Timeout.

I also notice that without some decent network security (eg https) or
virtual webserver presentation on the local side, using myopenhab/openhab
cloud presents a security risk to your openhab device/network. If you are
going to use these online services, make sure not to leave yourself
exposed. I’m sure that’s common sense to most.

I am facing the same issue, difference being that I am using Apache2 (SSL enabled) for reverse proxy purposes. I tried Nginx for testing (using the configuration suggested in the Getting Started guide) with the same result.

In both instances, the cloud connector drops the connection, according to the log.

When I bypass the reverse proxy (using http://my-openhab-cloud:3000), openHab establishes the connection and openHab cloud shows openHab as “online”.

It also works ok with, so obviously, the issue must be with the reverse proxy configuration. I certainly do not want to use an unsecured connection on port 3000 for anything else than testing, so any suggestions on how to fix it or work around the issue is highly appreciated :slight_smile:


openHABian is known to be working with Nginx, maybe you can “sniff around” in the conf files on github to find out how it is configured.

Thanks for the suggestion. Will look into it when I find the time…

Is it correct to conclude from this discussion that the openHAB2 Cloud Connector with presents some potential security challenges?

I was just setting it up and stumbled across the same Nginx proxy issue (showing offline in But instead of pursuing this further, I will now consider running my own instance of Cloud Connector, somewhere on Azure or AWS…

Thank you for your post. My Java was to old, to connect to the cloud service, too.

Meanwhile your urls are to old. Oracle has moved the old 111 packages, so you get a 404 try to install it with your solution.

For me it worked with:

echo “deb trusty main” | tee /etc/apt/sources.list.d/webupd8team-java.list
echo “deb-src trusty main” | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp:// --recv-keys EEA14886
apt-get update
echo debconf shared/accepted-oracle-license-v1-1 select true | sudo debconf-set-selections
echo debconf shared/accepted-oracle-license-v1-1 seen true | sudo debconf-set-selections
apt-get install -y oracle-java8-installer

As you can see, instead of “wily main” in the old url, use “trusty main”

Thanks for updating this! For the record as well, trusty should be still compatible with debian jessie, since it is the same base

I am considering of trying out the zulu java. They have it in openhabian as well, due to license reasons I believe.

Edit: actually I’m curious to hear what error you got. I can see wily still in the repository

hi Detorice. Thank you for you update it worked.
General advice for those who are copying and pasting from above message.
remove numerical 5 after /ubuntu
also copy past repalces the "with a . so ensure the quotes are as it is. Can be annoying as its too tiny a change to notice and your wondering what I doing wrong!!
thanks for your post!! the Java was updated and it works

I had the same issue after changing my system from raspberry to mach and the following steps did work for me:

I filled my account with the new uuid and pw and still got offline error.
Only ting helped was to delete my account and create a new one, confirm the email and restart openhab.