Openhab connection to google home app disappeared and cannot be recreated

i had a working connection to openhab from google home app. I could control my light by using voice control with google home. one day the service was gone in the google home app and I cannot create a new one. after every new linking it says ‘openhab has been linked’ but the link is not done and I cannot see any items. no lamps, nothing. and the link under services is also gone. foscam and ewelink keep working. openhab is gone and won’t come back. any ideas ???
openhab still works as a standalone app to switch on lights so RPI still ok.

Sorry to hear you’re having issues. Let’s start with a couple of questions:

  1. Did you make any recent changes to OH before noticing that it stopped working? I assume not.
  2. Is openHAB showing up in as “Online”?

Hi Russ, thank you for your response.

so I made no recent adaptions to the openhab items.default or other.
openhab is online and fully functional through the app.

I have made some changes to the openhab settings belonging to IFTTT and now I’m able to link Google Home App to Openhab again. just luck?

so problem solved, but I still do not know why the link (GHA - OH) disappeared in the first place.

thanks again.

By “belonging to IFTTT”, do you mean the exposed items in PaperUI? That shouldn’t have any impact on the Google Assistant service, but maybe it spurred a change that enabled GA to see your items again. Glad it’s working!

exactly. it worked like a charm even with the paper ui mods for IFTTT, but still the link disappeared. weird and annoying. so I guess it is as you say, at least it triggered GHA to find OH again. case closed, but without any real reason. thanks for your support !