Openhab crashes: sometimes multiple times a day, sometimes once a week

Anyhow, not sure where I should post this so if it’s in the wrong spot, I’dd appreciate someone correcting me.

So, about 2 months ago I Migrated my OH setup to a rpi2. Before I did this I didn’t have any issues with openhab crashing, now almost daily, but most days it will crash multiple times, other times it will run for a week or so without crashing.
this is what the terminal says:

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x7655a07c, pid=3404, tid=1946682480

JRE version: Java™ SE Runtime Environment (8.0-b132) (build 1.8.0-b132)

Java VM: Java HotSpot™ Client VM (25.0-b70 mixed mode linux-arm )

Problematic frame:

V [libjvm.so+0x16507c] CounterDecay::do_method(Method*)+0x14

Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again

An error report file with more information is saved as:

/opt/openhab/hs_err_pid3404.log

If you would like to submit a bug report, please visit:

http://bugreport.sun.com/bugreport/crash.jsp

Aborted
./start.sh: 34: ./start.sh: -Djava.compiler=NONE: not found
./start.sh: 35: ./start.sh: -Xrunjdwp:transport=dt_socket,address=8001,server=y,suspend=n: not found

Any help would be very much appreciated

This used to happen to me every couple of days.

Whilst I have little solid evidence to prove that this is a solution, I made the recommended changes regarding the tmpfs and reduced the overclock on my RPi2 and it’s been solid ever since.

1 Like

I recommend installing the Oracle JDK 1.8, do not overclock, and use the apt-get method of installing openHAB and the addons.

I don’t understand, the “do not overclock” part, in raspi-config the max overclock setting is rpi2 1000mhz, isn’t this the correct setting for a pie 2?

and another followup question, if I install the oracle JDK will I need to remove the previous jdk?
and can you point me to a guide of doing so?

Thank You for your advice, I modified my tmpfs file, I left the overclock setting at rpi2 because it’s a pie 2, hopefully this works, only time will tell. but Thank you very much for you efforts.

The Raspberry Pi 2’s default clock speed is 900MHz. This link might have the full answer.

You don’t need to worry about the other JDK; it can stay in place.

sudo apt-get install oracle-java8-jdk

Just verify after the above the you are using the Oracle JDK with java -version.

it seems I already have oracle installed but I’m not sure the version looks correct, does this look good?

pi@RPI-BACKEND /opt/openhab $ sudo apt-get install oracle-java8-jdk
Reading package lists… Done
Building dependency tree
Reading state information… Done
oracle-java8-jdk is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 46 not upgraded.
pi@RPI-BACKEND /opt/openhab $ java -version
java version "1.8.0"
Java™ SE Runtime Environment (build 1.8.0-b132)
Java HotSpot™ Client VM (build 25.0-b70, mixed mode)
pi@RPI-BACKEND /opt/openhab $

Looks correct. My Java on RPi2:

$ java -version
java version "1.8.0"
Java(TM) SE Runtime Environment (build 1.8.0-b132)
Java HotSpot(TM) Client VM (build 25.0-b70, mixed mode)

Odd things can happen if you’re not at the standard clock settings. Possibly other causes for crashing, too. FTR, I never see JVM crashes on my RPi2 setups with openHAB.

OK, thank you very much for your help, I will clock it back to standard specs. It seems like it’s been solid since I modified my tempfs file, but I probably don’t really need the extra 100mhz rather be safe. Thanks again for your help

1 Like

Thank you for all the help guys, My pie has been stable for 2 days straight now

1 Like

Glad to help!