OpenHab CUL ESA2000?

I Have CUL and my ESA2000 was working with FHEM before i switched to openhab

Does anyone know how i can get this working again with openhab =?

You can currently use the jeelink thing for your CUL. The commands you have to send to initialize the CUL go into the Init Commands parameter of the thing. This should allow to receive readings. What is missing is an ESA2000 thing and some code that parses the reading and transforms it into updates of openHab channels.

In order to implement this, I would need some TRACE output from you after you have created the Jeelink thing and configured the init commands. From what I have read, you should see something like

S A3 0543 031E 0000099C 0064 001147 000F

in the output. If you get output like this, I can check FHEM code so I know how to parse and transform it.

Hey Volker,

dont understand all of that :slight_smile:

I have beside the CUL also an Jeelink stick (for the old jeelink thermostats)

What i must exactly do and gave you that you can try to figure out the translation ?

Sorry my bad english - also german like you i guess :smiley:

First you have to create a thing for your CUL in OpenHab:
Use the Paper UI, go to the inbox, press the “+” button, select “Jeelink Binding”, then press “Add Manually”. Select “JeeLink USB Empfänger” and enter the port for your CUL and the initialization commands.

Next connect to the OpenHab console and enable TRACE logging for the jeelink binding:

log:set TRACE org.openhab.binding.jeelink

You should now get lots of messages in the OpenHab log showing everything that can be read from the CUL (and from your jeelink). If you have the init commands right, there should be lines like

Read line from port /dev/ttyXYZ: S A3 0543 031E 0000099C 0064 001147 000F

If that does not work, PM me in german and we can see if we can figure out what the problem is.