openHAB Designer dont work

Never got the designer to work because of the annoying syntax error. Configured openhab manually by editing text files. Next obstacle was changing the color of my Aeon Labs Light Bulb. Isn’t possible in openhab 1. So I removed everything and installed openhab 2, manually. It runs in a terminal session. Now I want to install it as a service using the command openhab:install-service. Starting the runtime now results in the same darn syntax error: Syntax error: “(” unexpected.

Who can please help me getting rid of these show stopping syntax errors?! It takes away all my pleasure in experimenting with openhab. And I’m seriously thinking of moving back to Domoticz because I’m not a java expert (yet).

In another thread you mention your are on ODROID Hardware.
Maybe you should open a new topic with a more specific header, something like “Not able to install OH2 on Odroid as a service”.
Only a few people here are on a Odroid and in this way you can better get their attention.

Good luck, don’t give up, most people love OH :slightly_smiling:

Thanks! I already played with these thoughts as I wrote it down. I will open a new thread and ask some relevant questions there.

I tried installing the designer on Ubuntu last night, and after updating the ini file with the following it started working
-Dorg.eclipse.swt.browser.DefaultType=mozilla to openHAB-Designer.ini

However, whenever I attempt to connect to my openhab.cfg file, it tells me that it can’t use it because of
Cannot create linked resrouce '/config/config'. The parent resource is not accessible
Both the openhab.cfg and openhab_default.cfg are in the same folder, but it should be noted that both are under /etc/ and not /opt/ as indicated in the manual install instructions

The items from my item config are showing up as expected.

I should note that I used the apt-get install method, not the manual method. If that’s the source of my headaches, then I can move to manual and remove the openHAB apt-get package.

1 Like

I installed the designer as explained in getting started on my raspberry pi (model A) in a separate folder at the /opt/-folder.
When trying to start openhab-designer it looks like its not there!?

pi@raspberrypi:/opt/openHAB-designer $ openHAB-Designer
-bash: openHAB-Designer: opdracht niet gevonden

this seems a siple problem but don’t know where to look.

other question: can I run openhab designer on my laptop while the raspberry is hosting the openhab runtime/addons

1 Like

Yes, you need to setup a samba share, take a look here:

I don’t think that is a good solution: the Pi model A has, what I have read, not enough cpu power to run openhab designer … but I have never tried it …

ok thx, will try tomorrow, will post feedback on that cpu power :wink:

habmin in raspberry runs (but slow) and with errors if I want to save something, so that-one I’m not going to use.

openhab-designer on my windows-computer shows perfectly the files on the raspberry but I do not have the root-rights to save the changes. (drive mounted by SFTP Net Drive as user ‘pi’)
I do not know how to login as ‘root’. Anyone?

3th option through PUTTY I need to open all files with sudo so I can save the changes. (not that user-friendly)

getting a bit frustrated :slightly_smiling:

Found the solution:

sudo chown -hR pi /opt/openhab

  • pi: user that is used to login over ssh (via sftp net drive free)
  • /opt/openhab : your openhab runtime folder

Hi sihui

I seem to be suffering the same issues as in this thread.
Using a Raspberry Pi 2 (with fast clock enabled and Ethernet connected to my home network) I started by installing openHAB and getting it up and running by copying the default configuration file openhab_default.cfg and naming it openhab.cfg making the necessary deltas, then hand crafting .sitemap .item and .map files, which I then tried to view via my Win 7 box with Internet explorer 11 (http://openhab.local:8080/ It failed. I then tried Chrome (Version 51.0.2704.84 m) and it worked fine. I also tried iOS and Andriod openHAB APPs and they worked (more or less).
Now because I found the hand crafting thing a PITA I wanted to use openHAB Designer to help with the syntax validation etc. and I know this software works as I saw it demoed on YouTube by Kai Kreuzer and Thomas Eichstädt-Engelen on ‘Home Automation for Geeks’, Allbeit with iOS on a MAC.

Although I possess a MAC Mini, a Linux Box I wanted to use one of my Win 7 boxes to do the work, mainly for convenience (I am writing a blog post and most of the readers have Windows boxes). So I mapped my Raspberry Pi openHAB install via Samba so I could see it from my Win 7 Box. No issues here.
Then installed the openHAB Developer (basically unzipped it) as I already had Java 1.8.0_92 on Win 7 Box. This Failed.
After some routing round (, I found I needed the 32bit version of Java so I installed ‘jre-8u92-windows-i586.exe’.
I decided to edit the ‘openHAB-Designer.ini’ file (rather than the shortcut), adding -vm C:\Program Files (x86)\Java\jre1.8.0_92\bin\javaw.exe. And Bingo it worked!
I followed step 3. of ‘Installing the openHAB designer (optional)’


3.Select the “configurations” folder of your runtime installation in the folder dialog that is shown when selecting the “open folder” toolbar icon.

No issues here. I was able to to view all my files I had created earlier; .sitemap, .item and .map. However, when I tried to use the internal web browser the software would consistently lock. On every occasion I needed to use the Windows Task Manager to kill the thread.

Basically I can’t get the Windows install of openHAB-Designer to work. No matter how hard I try. So I gave up with the Windows version.

Not put off by this I thought I would try to install openHAB-Designer on the Raspberry Pi and use XMing to forward to my Win 7 box and edit from there.

So I installed on the Raspberry Pi (as I have a Pi 2 and I believe this is a 32bit ARM Core I chose the 32bit version of OpenHAB Designer) under ‘/opt/openhab-designer’. As per ‘

I followed these steps (from the command line on the Pi);

sudo mkdir /opt/openhab-designer
cd /opt/openhab-designer
sudo wget
sudo unzip

Before I start to attempt using XMing I really want to ensure the software fully functions from the Raspberry Pi. However everytime I try to run the software ‘openHAB-Designer’ it fails.

The Raspberry Pi is running ‘2016-03-18-raspbian-jessie’ a pretty recent distro. Besides I always run an apt-get update upgrade to make sure I have the latest.

I’ve tried running from /opt/openhab and nothing works.

An ls - l of /opt/openhab-designer gives

================== ls -l ==================
pi@OPENHAB:/opt/openhab-designer $ ls -l
total 111340
drwxr-xr-x 2 root root 4096 May 22 21:42 addons
-rw-r–r-- 1 root root 85642 May 22 21:41 artifacts.xml
drwxrwxrwx 5 root root 4096 May 22 21:44 configuration
-rw-r–r-- 1 root root 113502967 May 22 20:05
-rw-r–r-- 1 root root 15551 Aug 21 2012 epl-v10.html
drwxrwxrwx 25 root root 4096 May 22 21:24 features
-rwxr-xr-x 1 root root 266168 May 22 21:41
-rw-r–r-- 1 root root 9229 Aug 21 2012 notice.html
-rwxr-xr-x 1 root root 63050 May 22 21:41 openHAB-Designer
-rw-r–r-- 1 root root 283 May 22 21:42 openHAB-Designer.ini
drwxrwxrwx 4 root root 4096 May 22 21:44 p2
drwxrwxrwx 12 root root 36864 May 22 21:44 plugins
drwxrwxrwx 2 root root 4096 May 22 21:44 readme

I’ve tried the following command line incantations.

Attempt 1

/opt/openhab-designer $ openHAB-Designer


-bash: openHAB-Designer: command not found

Attempt 2

/opt/openhab-designer $ ./openHAB-Designer


-bash: openHAB-Designer: cannot execure binary file: Exec format error

Attempt 3

/opt/openhab-designer $ sudo openHAB-Designer


sudo: openHAB-Designer: command not found

Attempt 4

/opt/openhab-designer $ sudo ./openHAB-Designer


./openHAB-Designer: 1: ./openHAB-Designer: Syntax error: “(” unexpected

What am I doing wrong?

Any help would be greatly appreciated.




Ahhhh. Update.
Just done some more googling.

See here.!topic/openhab/-Ol42n-USn0

Straight from the horses mouth so to speak. Kai posted on 23/10/2013.

‘The Designer is indeed not meant to be executed on a RaspPi - it should be used on some desktop computer instead. As you correctly figured out, it is build for x86 architectures and has quite a big footprint (just like the Eclipse IDE). My usual suggestion is to simply use a Samba share to access the configuration files on your RaspPi from the Designer; more elegant ways might be offered in future’


So my question would be. Why is my PC install of openHAB-Designer not working?

Looks great to me, designer is working!

When I remember correctly, there are some issues with the internal browser. It’s a lot more convenient to use the regular browser, that’s the reason I have never used the internal browser.

Hmmm, what part doesn’t work? How do you access your files, via Samba? Because all what I have read now in your post, it’s working fine …

Here is an example of an smb.conf which works fine at my Win desktop computer:

Good luck.

Hi sihui,

I appreciate the quick response.

Apologies for misleading statement [in mitigation, it was a long email, I was bound to make at least one mistake :slight_smile: ] I meant to say I couldn’t get the full openHAB Designer software working - ie. inclusive of internal browser functionality (when I publish the blog post there will be some whinges if everything is not laid out on a plate). I have in fact been working round the issue by doing exactly what you suggest. I’m using chrome which although can be a bit slow to pick up changes (actually a little on the nondeterministic side at times) works sufficiently well for me to crack on.

More importantly you’ve given me absolution through confirmation.

I kept the pi log in so run a chown as below from time to time and editing things seem to be ok.

sudo chown -vhR pi:pi /etc/openhab
sudo chown -vhR pi:pi /usr/share/openhab

My samba settings are as follows

comment= Home Directory
only guest=no
create mask=0777
directory mask=0777

[OpenHAB Home]
comment= OpenHAB Home
only guest=no
create mask=0777
directory mask=0777

[OpenHAB Config]
comment= OpenHAB Site Config
only guest=no
create mask=0777
directory mask=0777

Like you I’m not a Linux Guru, but as my IoT devices, MQTT server, MySQL and openHAB servers are on their own closed network I think security isn’t too much of an issue (for now).

Anyway, thanks for your help



Maybe you can avoid that by adding:

force user = openhab
force group = openhab

or pi:pi if you changed the default openHAB user.


I’ll give this a shot.



Hi all,

Wasn’t sure whether to revive an old thread here or post a new topic, but I’m having an issue with the designer on Windows 10.

I’ve tried bit the stable version (updated last almost a year ago!) as well as the snapshot but both do not have the editable workspace available. I can browse to my conf files but cannot open any of them.

This happens on my raspberry pi installation as well as a windows installation I did as a test.

In the screenshot above there is a ‘no-entry’ sign attached to the file I’m dragging to the editor.

Any ideas why this is happening?

I went according to the guide at

Double check your samba conf (lots of examples here in the forum), make sure you have 32Bit Java on your Win installed, make sure you are using designer 0.8 (not the 0.9 version).
Apart from that I have not seen that problem before.

It’s not recommended to use the designer on a Pi. Configure your samba share accordingly and access your files from your Win computer. Much better performance …

Hi @sihui

Still can’t edit any files :frowning:

  1. My samba conf I think is ok since I can navigate to the conf directory and edit the files with notepad++.

  2. I uninstalled my 64 bit Java and installed 32 bit

  3. I added the JRE to the PATH and JAVA_HOME environement variables.
    4.My designer version is 0.8

So that setup didn’t work. I tried then to install the 64 Bit designer (kept the same Java though)

I’m trying two things here…

First is to open and edit files on my local OH2 installation on my Windows 10 laptop. Can’t edit files.
Second is to access the files on the Pi using samba (to browse to the config folder on the Pi which I can see), but can’t edit files there either.

So both ways aren’t working.

I saw that Zulu Java is the recommended platform now so I thought I would have a go so I installed it on my laptop.

The version installed is: (I didn’t find a 32 bit Windows release)

Now the OH2 runtime doesn’t start with the following output:

I think the path settings are ok since ‘java -version’ returned fine.Is Zulu ok for Windows?

I’m stumped? I would really like to start working with the designer

Switching back to Oracle Java allowed the OH2 runtime to kick-off fine.

Designer (64 bit) then threw me this…

Installed Designer 32 bit again and it loads, but again not editable, but no error. So it seems like something to do with my Java installation.

Thanks @sihui, I will follow your steps verbatim and see if there’s any joy. I’ll post any findings.

Good, no problems there I guess.

I can only tell you what I did to make it work:

Win 10 64Bit, installed Java 32Bit from here, installed 32Bit designer 0.8 from here, navigated to the config folder through the samba network share and am able to edit my files.
No need to edit any path or home directories.

Don’t drag them, try double clicking them instead. Dragging doesn’t work for me either.