OpenHAB designer stopped working for no obvious reason

I have finally found an evening to get a couple more simple Homie ESP8266 nodes working (to let me know if there is any water on the floor next to the washing machine or dishwasher) - and they are, and so is OpenHAB.

To date I have done all my development work for OpenHAB using the Designer (it’s great!)… And today when I run it, absolutely NOTHING happens - no error message, nothing. I am running on Windows 10 (sorry folks…). As far as I know, I have changed nothing since the last time I ran it (two or three months ago).

I tried running it at the command prompt, with compatibility mode set to Windows 7, with administrator rights - nothing. (At the command prompt I just get returned immediately to the prompt with no feedback whatsoever.)

Could this be the result of a windows or Java update I wonder? Does anyone have any ideas for how to proceed with diagnosing the problem?

Many thanks for any suggestions!


If it is a Java update, you can try going back a version or jumping to Java 9 (if you are on 8). Beyond that I’ve no ideas.

Thanks Rich. I have today also tried downloading the latest version, and also turning on debugging in Java - nothing.

I am right in thinking presumably that installation is just a matter a of unpacking the zip file in a directory like C:\OpenHAB\OpenHAB designer (that certainly worked until recently)?

If no one else is having trouble with the latest production version of Java then the problem must be somewhere else. I am running low on space on the C drive but the rest of the PC is working fine, so this doesn’t seem very likely as the cause…

You are correct, installation is just unzipping. Running low on disk space wouldn’t cause this problem.

I’m doubtful that this issue is the same as i was having, mine was trying to use a 32-bit java when i only had 64-bit installed. So like @rlkoshak advised me, attempt either a 64-bit designer or downloading a 32-bit java version (You can run multiple versions of java at once but if they’re not being used its advised to uninstalled the unused versions for security reasons).