openHAB-Designer throws JAVA error on start in Linux-Mint

I very new to OpenHAB, having just got the runtime running. When I tried to run Designer I received the following error message:

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x00007f2b096d22a1, pid=12843, tid=0x00007f2bac3d3700

JRE version: Java™ SE Runtime Environment (8.0_101-b13) (build 1.8.0_101-b13)

Java VM: Java HotSpot™ 64-Bit Server VM (25.101-b13 mixed mode linux-amd64 compressed oops)

Problematic frame:

C [] soup_session_feature_detach+0x11

Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again

If you would like to submit a bug report, please visit:

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

I am equally new to JAVA so any suggestions on how to fix this would be appreciated.

Did you download the 64-bit Designer for Linux?

Thanks for the reply Rich.

I downloaded “” I will try again downloading and opening in another location to see if that helps.

I just downloaded and successfully installed OpenHAB on Windows10, ran the demo, and successfully opened OpenHAB-Designer. Now that I have a fully functioning system I can explore and learn how to use OpenHAB. Eventually I will have to master a Linux installation since it is my intention to use the system on a Raspberry Pi installation. However, for now, the pressure is off.

Apparently this has to do with the built in browser. In searching about the libsoup error I found this:

The workaround is to add:

-Dorg.eclipse.swt.browser.DefaultType=mozilla to the vmargs of the openHAB-Designer.ini file.

The built in browser still doesn’t work, but at least the designer will start in Mint 17.3.

1 Like

Thanks for the response Glenn-

I tried your suggestion and openHAB-Designer now opens. However, when I tried to load the demo configurations file I got the following error message: “An error occurred while opening the configuration folder” The error details were: “cannot create linked resource ‘/config/config’. The parent resource is not accessible.” In the “Internal Web Browser” tab I received a message that the “Embedded browser not available”. The Problem Details stated: “The embedded browser widget for this editor cannot be configured in order to support the embedded browser.” under the Details icon: "No more handles [Could not detect registered XULRunner to use] org.eclipse.swt.SWTError: No more handles [Could not detect registered XULRunner to use] this was followed a large number of entries all starting with