Openhab Designer won't start on macOS

Hi everyone,

I’m trying to run Openhab Designer on macOS Sierra but the only thing I get is a blank window (see below).

Then I get a fairly huge log file. Here’s a small sample, but it goes that way for a few hundred lines.

!SESSION 2017-01-17 23:04:29.484 -----------------------------------------------
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_CA
Framework arguments:  -keyring /Users/jeffreychausse/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/jeffreychausse/.eclipse_keyring -showlocation

!ENTRY org.eclipse.update.configurator 4 0 2017-01-17 23:04:34.803
!MESSAGE Could not install bundle plugins/ch.qos.logback.classic_1.0.7.v20121108-1250.jar   Bundle "ch.qos.logback.classic" version "1.0.7.v20121108-1250" has already been installed from: reference:file:plugins/ch.qos.logback.classic_1.0.7.v20121108-1250.jar

!ENTRY org.eclipse.update.configurator 4 0 2017-01-17 23:04:34.805
!MESSAGE Could not install bundle plugins/ch.qos.logback.core_1.0.7.v20121108-1250.jar   Bundle "ch.qos.logback.core" version "1.0.7.v20121108-1250" has already been installed from: reference:file:plugins/ch.qos.logback.core_1.0.7.v20121108-1250.jar

!ENTRY org.eclipse.update.configurator 4 0 2017-01-17 23:04:34.807
!MESSAGE Could not install bundle plugins/ch.qos.logback.slf4j_1.0.7.v20121108-1250.jar   Bundle "ch.qos.logback.slf4j" version "1.0.7.v20121108-1250" has already been installed from: reference:file:plugins/ch.qos.logback.slf4j_1.0.7.v20121108-1250.jar

I’ve tried updating Java to latest version without any success. I’ve also tried installing on Windows 10 but I get the same error with the same log file. Please note that I am NOT using Openhab2. I just need to control a single light for a demo, so I’m looking for the simplest way to achieve this.

java version "1.8.0_112"
Java(TM) SE Runtime Environment (build 1.8.0_112-b16)
Java HotSpot(TM) 64-Bit Server VM (build 25.112-b16, mixed mode)

Thank you for your help!


You need the Java JDK to get this going. You “only” have installed the Runtime Environment (JRE). Download the JDK from and install it.

Furthermore, the Designer has to be started from the programs folder. Don’t put it into downloads or something! Otherwise Apple security features will prevent the software from running correctly.

I now have JDK installed and it is working. Thanks! When I enter java -version though, it still indicates that I am using JRE. JDK is not listed…

Same for me…